Export data in Model Builder:

21854
5
05-31-2011 07:53 AM
MarkEnglish
New Contributor II
I am working with a model (9.3) which creates an event layer (x,y coords) as an import parameter.  Further analysis is required on that x and y coordinate, although I can't run the geoprocessing on the event layer.  I tried adding 'Export Data' to the model, to export to a feature class for further analysis, but 'export data' won't work in model builder when trying to drag and drop.  Is there a method to make export data work in model builder, or an alternative approach to transform the event layer to a feature class or shapefile.  Thanks!
0 Kudos
5 Replies
PaulVastag
New Contributor III
Did you find a solution?  I'm working on the same problem - trying to create a point feature class from an XY event layer using geoprocessing tools in ModelBuilder.
0 Kudos
DaleHoneycutt
Regular Contributor
Use the Copy Features geoprocessing tool.  It's in the Data Management toolbox > Features toolset.
0 Kudos
MarkEnglish
New Contributor II
Copy features did not work for my purposes.  Since I was working with Network Analyst outputs, which can potentially kick out 4 temporary 'memory' layers.  I had to use 'select data' to kick out the individual 'memory' layers.  Keep in mind that these results are temporary (no solid feature class was created).

If you are simply trying to generate a tangible point dataset from an event layer, dmhoneycutt suggested copy feature.  If that doesn't work for you, I used 'feature to point' which generated an actual point file. Good luck...

I'm still tackling issues in model builder.
1)  I would like to kick out reports from model builder, or simply the attribute table.
2)  I would like to utilize other formats (dbf, xls, etc.) on the front and back ends of models.  For an example:  To begin a geospatial model with a dbf or excel file, and/or kick out a dbf or excel file as the final process of a model.
Mark
0 Kudos
Fernandotello
New Contributor

To export data use tool select under Analysis Tools - Extract. Be sure the tool do not have the mark intermediate for working and you can export to any format(?). I'm not sure about this last, but for me it's work in many cases.

0 Kudos
pcampbell
New Contributor

Hi Mark, I realize this is going way back now, but wondering if you (or anyone else) found a solution to this issue? I'm dealing with a similar case: trying to use export in ModelBuilder to create a table from a point feature class. 

0 Kudos