euclidean distance output is clipped

2329
5
10-21-2011 03:41 PM
by Anonymous User
Not applicable
Original User: chocolatte

Hi,
I'm trying to create an embossed effect for some counties based on the tutorial posted in the Mapping Center.
http://blogs.esri.com/Support/blogs/mappingcenter/archive/2011/09/13/Creating-an-Embossed-Effect-for...

For some reason, when I try to get the euclidean distance for the buffered dataset, the euclidean result is clipped where it shouldn't be. I've tried setting the analysis mask and analysis extent in spatial analyst to extents greater than the final output, but the output still gets clipped the same areas. I tried setting the max distance in the euclidean distance dialog to a distance that was beyond the final extent, but the output is clipped.

I've attached a few images that show the clipping issue. The same areas get clipped no matter which settings I change. It almost looks like it is being clipped to a rectangular extent, but I don't know where the setting would be to check this.
Any insight would be appreciated. I'm using ArcGIS 9.3.1 with the latest service packs.
Thanks,
Charlotte
0 Kudos
5 Replies
MarkEllis
New Contributor II
It looks suspiciously like your second output is only being processed to the extent of the internal buffer layer.  Make sure that your environment settings for the tool define the processing extent to be the larger county layer.
0 Kudos
by Anonymous User
Not applicable
Original User: chocolatte

That's what I thought at first so in Spatial Analyst I changed the analysis mask and analysis extent to the county layer and still got a clipped euclidean distance grid. I changed the mask and extent setting to an area even greater than the county and the euclidean grid was still clipped. Clipping always occurs in the same areas. If it helps, I set the buffer size to -5000 meters to create an internal buffer and set the euclidean max distance to 5000 meters. I even tried setting the euclidean max distance to 8000 meters thinking it would capture the extent I needed and then I could clip to the county, but clipping still occurred.

I tried euclidean distance on a couple of other shapefiles and came up with a clipped result (see attached).

Charlotte
0 Kudos
CharlottePeters
New Contributor III
I figured out the problem. I was using the eucliden distance tool from the Spatial Analyst toolbox in ArcToolbox for my processing, which produced clipped results.  When I used the straight line distance tool from the Spatial Analyst extension everything worked out as expected.

Charlotte
0 Kudos
by Anonymous User
Not applicable
Original User: blambe

Hi guys,

I know this thread is a bit old but i am having the same problem in Arcmap 10.0...and its ridiculously frustrating

Although you found a temporary go-around...why is the Euclidean Distance tool still clipping? In fact, it happens in all my Spatial Analyst tools (Density, Distance, etc.):

using the Kernal Density tool:
[ATTACH=CONFIG]22330[/ATTACH]



Using the Euclidean Distance tool:
[ATTACH=CONFIG]22331[/ATTACH]


Under  Environments>Raster Analysis, I have cell size set to "Maximum of Inputs". The mask and extent setting (where applicable) is set to an area greater than that of the layers....any ideas?

I am using Arcmap 10.0, Spatial Analyst and have service pack 3 installed
0 Kudos
HalBrindley
New Contributor

I was just having this same problem and it was killing me! This video solved it for me: https://www.youtube.com/watch?v=AYbUUsdrC04 but here are the basics: when using the Euclidian Distance tool, click the "Environments" button at the bottom and then click "Processing Extent". Here change the default to something else. The easiest is just to use "Same as Display" but make sure you've zoomed out far enough to hold everything before you open the tool! Works perfectly!

0 Kudos