Add Spatial index to versioned feature class

164
2
12-21-2018 02:08 AM
MartinMaretta3
New Contributor

Hi All,

I try to add spatial index to versioned feature class (Oracle SDE) using toolbox "Add Spatial Index" in arcgis 10.6 . When I try it as Data owner I have error message -"Tool must be run as owner of SDE.Default version". But when I try to run it as SDE user I have error message "Tool must be run as Data owner".

So I am little bit confused. Do you have any idea how to solve this problem? PS: I can do that in ArcCatalog as Data Owner, but I need to run via toolbox as batch process.

Thanks, Martin

0 Kudos
2 Replies
RobertBorchert
Frequent Contributor II

The spatial index should be created automatically when you import data into the feature class and it is maintained by the GIS. 

If you need to rebuild it. 

You may need to unregister as versioned first.  You also need to do it when nobody else is on the system.  It is a very resource intensive process. Your best bet may be to export the feature classes to a filegeodatabase and allow it to be built automatically.  Then import them back into your database

http://desktop.arcgis.com/en/arcmap/latest/manage-data/geodatabases/modifying-a-spatial-index.htm

0 Kudos
MartinMaretta3
New Contributor

Hi, thanks for reply.

Problem is that I could not unregister as versioned, because we have lots of versions. I need recreate spatail index just after recalculate of extent. But maybe running rebuild index tool will be enough.

0 Kudos