X-Ray for ArcCatalog Help - saving xml in incompatible format

634
0
05-07-2021 09:47 AM
Labels (1)
bkaycodev
New Contributor

How do I solve the problem of X-Ray changing the xml from UML to UTF-8 when it saves the edits? Is this something to do with the template or style sheet xray is accessing?

It didn't do this before.  Seems to happen after Office 365 install?

ORIGINAL XML

 

<esri:Workspace xmlns:esri='http://www.esri.com/schemas/ArcGIS/10' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:xs='http://www.w3.org/2001/XMLSchema'><WorkspaceDefinition xsi:type='esri:WorkspaceDefinition'>
<WorkspaceType>esriLocalDatabaseWorkspace</WorkspaceType>
<Version></Version>
<Domains xsi:type='esri:ArrayOfDomain'>
<Domain xsi:type='esri:CodedValueDomain'>
<DomainName>cvdCDOTSurfCond</DomainName>
<FieldType>esriFieldTypeString</FieldType>

 

 

SAVED XML

 

<?xml version="1.0" encoding="utf-8"?> 
<esri:Workspace xmlns:esri="http://www.esri.com/schemas/ArcGIS/10" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet"> 
<!--Themes: --><WorkspaceDefinition xsi:type="esri:WorkspaceDefinition">
<WorkspaceType>esriLocalDatabaseWorkspace</WorkspaceType>
<Version />
<Domains xsi:type="esri:ArrayOfDomain">
<Domain xsi:type="esri:CodedValueDomain">
<DomainName>AnnotationStatus</DomainName>
<FieldType>esriFieldTypeSmallInteger</FieldType>
<MergePolicy>esriMPTDefaultValue</MergePolicy>
<SplitPolicy>esriSPTDuplicate</SplitPolicy>
<Description>Valid annotation state values.</Description>
<CodedValues xsi:type="esri:ArrayOfCodedValue">

 

 

 

 

Tags (3)
0 Kudos
0 Replies