What version of SDE server to we need to upgrade to, in order to obtain backward compatibility of feature class within a geometric network?

437
2
Jump to solution
07-18-2017 11:25 AM
GenaroGarcia
New Contributor III

Our running SDE 10.0 server with most all our clients using ArcGIS 10.2.2.  I upgrade my client development computer to ArcGIS 10.4.1.  I'm able to add simple feature classes into ArcMap without any issue.  But, when I try to add a feature class within a Geometric Network is get the following message.

 

"Error opening feature class

The feature class participates in a geometric network that could not be opened.

This SDE server does not support this client or operation."

 

I'm assuming that this is a compatibility issue.  Saying that, the question is,

What to version of SDE server do we need to upgrade in order to be backward compatible to obtain geometric network feature classes?

0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor

It looks like 10.3.x clients are the "newest" client that you can use to connect to an enterprise geodatabase at v 10.0.x

Client and geodatabase compatibility—ArcGIS Help | ArcGIS Desktop 

--- George T.

View solution in original post

2 Replies
George_Thompson
Esri Frequent Contributor

It looks like 10.3.x clients are the "newest" client that you can use to connect to an enterprise geodatabase at v 10.0.x

Client and geodatabase compatibility—ArcGIS Help | ArcGIS Desktop 

--- George T.
George_Thompson
Esri Frequent Contributor

I will also say that your enterprise geodatabase is on an unsupported version being on 10.0.x

--- George T.