Upgrade Geodatabase along with Oracle

295
1
Jump to solution
05-18-2020 03:30 AM
RedaAli
New Contributor III

We are Planning to upgrade Oracle Database from 11.2.0.1 to 19.3  & Geodatabase from 10.1 to 10.7.1

  Current environment :-                                           Upgraded Environment:-

 Geodatabase 10.1                                                   Geodatabase 10.7.1

 ArcGIS 10.1                                                              ArcGIS 10.7.1

 Oracle 11.2.0.1                                                          Oracle 19.3

The Planned Steps:-

 1. Backup DB using RMAN.

 2. Create a Testing Environment

 3. Upgrade Geodatabse on testing from 10.1 to 10.3  Version     Q ( is 10.3  compatabile with oracle 11.2.0.1 ?)

 4. Create a Full dump file from oracle db 10.3.

 5. Install oracle 19.3.

 6. Import SDE 10.3 schema                Q (is it compatabile with oracle 19.3).

 7. Import Other users schemas.

 8. Upgrade Geodatabase directly to 10.7.1

 8. Test the Results.

 9. if it is ok apply on production environment.

Please, help regarding the steps and compatability.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor

You will need to upgrade Oracle to 11.2.0.4. Then you can upgrade from ArcGIS 10.1.x --> ArcGIS 10.3.x/10.4.x; Upgrade a geodatabase in Oracle—Geodatabases in Oracle | Documentation 

 

Once at an newer release (ArcGIS 10.3.x/10.4.x), you can then upgrade to 10.7.1 (on the same version of Oracle). Once that is completed and verified you could them move to Oracle 19.x: Oracle database requirements for ArcGIS 10.7.x and ArcGIS Pro 2.3 and 2.4—System Requirements | Docu...   be sure to install this patch on the ArcGIS 10.7.1 clients; ArcGIS (Desktop, Engine, Server) Support for Oracle 19c Patch 

Hope this helps answer your questions.

--- George T.

View solution in original post

1 Reply
George_Thompson
Esri Frequent Contributor

You will need to upgrade Oracle to 11.2.0.4. Then you can upgrade from ArcGIS 10.1.x --> ArcGIS 10.3.x/10.4.x; Upgrade a geodatabase in Oracle—Geodatabases in Oracle | Documentation 

 

Once at an newer release (ArcGIS 10.3.x/10.4.x), you can then upgrade to 10.7.1 (on the same version of Oracle). Once that is completed and verified you could them move to Oracle 19.x: Oracle database requirements for ArcGIS 10.7.x and ArcGIS Pro 2.3 and 2.4—System Requirements | Docu...   be sure to install this patch on the ArcGIS 10.7.1 clients; ArcGIS (Desktop, Engine, Server) Support for Oracle 19c Patch 

Hope this helps answer your questions.

--- George T.

View solution in original post