Underlying DBMS errorFail to enable database option ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT

1432
10
Jump to solution
04-18-2018 06:04 AM
Highlighted
New Contributor II

I'm getting this type of error when try to Enable Enterprise Geodatabase:

Underlying DBMS errorFail to enable database option ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT.
Failed to execute (EnableEnterpriseGeodatabase).

But both option: 

- Allow Snapshot Issolation

- Is Read Committed Shanpshot On 

are set to True.

What else can be wrong?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor II

We found the cause of having this problem.

Name of database has '-' sign!!! On different environment it works just fine!!

And there was no information that he cannot connect to database!!!

When I change the name, it just start working!

View solution in original post

10 Replies
Highlighted
MVP Regular Contributor

Did you turn those settings to ON and then try the Enable Enterprise Geodatabase? Or tried to enable first, encountered the error, changed settings and then trying to enable again?

Close the ArcCatalog, reopen and try again...

Reply
0 Kudos
Highlighted
New Contributor II

1) First I set:

- Allow Snapshot Issolation

- Is Read Committed Shanpshot On 

to ON/True

2) Then I runned Enable Enterprise Geodatabase tool

3) ArcCatalog was closed and reopened many times, I was testing this for quite long time (I created also new database to check if maybe there is something was wrong with previous one, but still I get this error).

Reply
0 Kudos
Highlighted
MVP Regular Contributor
  • You are trying to create a DBO schema or the SDE schema geodatabase?
  • Have you tried the "Create Enterprise Geodatabase" tool?
Reply
0 Kudos
Highlighted
New Contributor II

1) SDE (user: sde, default schema: sde)

2) Create Enterprise Geodatabase result is:

User has privileges required to create database objects.
Database already exists.
Validated authorization file.
User has required privileges for geodatabase setup.
XML support is enabled for the database instance.
Underlying DBMS errorFail to enable database option ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT.
Failed to execute (CreateEnterpriseGeodatabase).

Reply
0 Kudos
Highlighted
MVP Regular Contributor

Well, I'll suggest trying to create a DBO schema gdb and check

Also, grant SDE the elevated permissions to alter those settings and try...

Reply
0 Kudos
Highlighted
New Contributor II

I created new database where SDE user is db_owner, and I set in user mapping => user:dbo, schema: dbo and ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT are both set for True for this database.

Error is the same:

Validated authorization file.
User has required privileges for geodatabase setup.
XML support is enabled for the database instance.
Underlying DBMS errorFail to enable database option ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT.
Failed to execute (EnableEnterpriseGeodatabase).

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hello Ewa- what version of version of SQL Server and ArcGIS DT / Pro are you using to run the Enable GDB tool from? Have any privileges been revoked from any user and / or the public role? Lastly, can you check the sde_setup.log file which should be located in the C:\Users\<username>\AppData\Local|\Temp directory. 

Reply
0 Kudos
Highlighted
New Contributor II

We found the cause of having this problem.

Name of database has '-' sign!!! On different environment it works just fine!!

And there was no information that he cannot connect to database!!!

When I change the name, it just start working!

View solution in original post

Highlighted
New Contributor

It was the dash for me as well!!

I tried different versions of SQL (2012, 2017), Arc (10.4.1 and 10.6), and gave sde db_owner to test.  Nothing worked until I removed the dash!!

Reply
0 Kudos