Unable to connect to the Geodatabase

360
9
05-19-2017 07:34 AM
Highlighted
New Contributor

When I am trying to connect to the Geodatabase with sde user but the connecting not establishing and getting a -51 error code with message "Underlying DBMS error". Previously I had no issue connecting Geodatabase but from a week I am getting this error.  I am using Oracle11g and ArcSDE 10.1.

Is this something related to ArcSDE or DBMS? If it is related to DBMS what could be the cause of the issue and how can I resolve it?.

Any help in identifying and resolving the issue is greatly appreciated.

Thanks in Advance.

Reply
0 Kudos
9 Replies
Highlighted
Esri Frequent Contributor

First Question: What has changed in the RDBMS or the client in the last week?

What version of ArcGIS Client are you using?

Are you using direct connection, if so what is the syntax? EZConnect or TNS?

Can you put a screenshot of the error?

Since it is Oracle, can you connect to the DB via SQLPlus or TOAD as the SDE user?

--- George T.
Highlighted
New Contributor

What has changed in the RDBMS or the client in the last week? : Database backup to clone and create new database in different server has been performed.

 

What version of ArcGIS Client are you using? : It is ArcGIS 10.1

 

Are you using direct connection, if so what is the syntax? EZConnect or TNS?: We are using EZConnect.

 

Can you put a screenshot of the error?: Unfortunately I don't have the screenshot with me. This is the only error message I get from the log file.

"Connection to SDE encountered a -51 error:

Underlying DBMS error

Extended error code: 0, extended error string:

Ends with status 1"

 

Since it is Oracle, can you connect to the DB via SQLPlus or TOAD as the SDE user?: Yes.

I am getting this error when I am connecting to the database using C++.  

I have published maps in the ArcGIS server and the data is visible in the maps.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Thanks for that information, I am not sure how to make a connection via C++.

Can you make a connection directly in the ArcGIS Client (Catalog/ArcMap)? What are the results?

--- George T.
Reply
0 Kudos
Highlighted
New Contributor

I tried connecting ArcGIS client(Catalog) and the connection is successfully established in it.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Ok, If you can connect to the Oracle GDB via Catalog that tells me that it is something in the C++ code that may need to be tweaked.

https://community.esri.com/community/developers?sr=search&searchId=46262adf-65f5-42c3-b52b-5fc319452...

--- George T.
Reply
0 Kudos
Highlighted
New Contributor

Hi George, 

I don't think there is any issue in that C++ code since it is a working solution for long from now. Besides the same code is working in other environment.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Ok, then a comparison between a "working" machine and this "non-working" machine needs to be made.

Have you reviewed the direct connection logs? Deciphering Errors within ArcSDE | Support Services Blog 

--- George T.
Highlighted
Esri Frequent Contributor

To add to George's list of questions - did the DEFAULT version permission get changed to PRIVATE by chance?

Highlighted
New Contributor

No, I have checked the DEFAULT version permission and it is in public mode.

Reply
0 Kudos