Spatial view registered in another instance

173
1
11-24-2020 09:26 AM
MichaelGinzburg
New Contributor III

Hello,

I have an ArcSDE 9.3.1 installation.

I need to recreate spatial view.

After I issued sdetable - o delete I'm getting error message that the view "is registered in another instance".

Afterward sdetable -o create reports success but the view is not created - I can't see it in ArcCatalog.

Did this after restart of ArcSDE service, and check that there's no connections.

There are 2 instances: SDE and the other.

It seems I need to unregister the views before delete. Will sdetable -o unregister unregister view from all instances?

Thanks!

 

Reply
0 Kudos
1 Reply
VinceAngelo
Esri Esteemed Contributor

ArcGIS 9.3.1 is very ancient. It's unlikely many here remember how the old command-line tools worked, or how to work around geodatabase corruption with the old-style geodatabase architecture. It would help if you provide details on the RDBMS and how you've deployed the software. It sounds as if you have Oracle with the now-deprecated user-schema geodatabases, but exact details are necessary. 

Generally, untangling a corrupted geodatabase would be a Tech Support call, but you're nearly a decade late for that. Any advice you receive now would come with a high risk of complete destruction of database integrity, so you might need to provide legal cover to anyone who could help (which would require a time and materials contract with appropriate indemnity).

The good news is that the pre-10 geodatabase architecture was more relational, but the bad news is that you're likely working without a net. Sorry.

- V