Problem with arcsde versioning after database crashed.

605
1
09-22-2016 12:55 AM
Highlighted
New Contributor

Hello,

I have a problem with versioning using ArcSDE. The customer has the following configuration:

- ArcSDE 9.3.1 (yes, I know it is an ancient version, but I cannot do anything about it) running on Windows 2008

- Oracle database 11gR2

- Arcmap 10.1 to edit data

Everything worked fine until last weekend the server with the database crashed. We restarted it, restarted SDE and it began working again. The only problem is with versioning.

When I start editing all edits are commited to the base version on the moment I make them. I cannot do undo/redo operations - they are inactive. When I stop editing I do not get the prompt dialog to choose if the data should be saved or not.

What we have done already:

- restarted SDE and database again

- unversioned and again registered as versioned (with moving edits to base) the whole dataset

- I prepared a new mxd file to make sure it is not the case

- I made sure that in Editor -> Options -> Versioning tab, the option to use versioning is enabled (I use Arcmap 10.3.1, but it seems that arcmap is not the problem).

Unfortunately nothing helped. Did I miss something that need to be set ? Generally I did not see any errors neither in ArcMap, ArcCatalog and SDE logs.

The funny thing is that we have another SDE instances running on the mentioned windows machine, but they point to different databases. And editing works fine with them. We have compared SDE schemas on those databases and found no differences.

Did anyone had similiar problems and could have any suggestions ?

If you need more information pleaase tell me and I will provide what is needed.

Tags (1)
Reply
0 Kudos
1 Reply
Highlighted
MVP Esteemed Contributor

Do you have a pre-crash back up you can restore?

Reply
0 Kudos