Problem enabling an enterprise GDB

1254
14
06-12-2017 07:22 AM
Highlighted
New Contributor II

I am having a problem enabling an enterprise geodatabase. When I try to run the tool, the log shows that it goes through a bunch of database steps successfully, and then it says:

[Thu May 18 09:59:58 2017] Error creating  GDB_Tables_Last_Modified table...
[Thu May 18 09:59:58 2017] ERROR Creating Geodatabase tables
, Error = -511
,EXT_Error = 0
,EXT_ERROR1 = Database user name and current user schema do not match.
,EXT_ERROR2 =
,

The database folks assure me that the database is setup per the instructions here: http://desktop.arcgis.com/en/arcmap/10.3/manage-data/gdbs-in-sql-server/setup-geodatabase-sqlserver....

 

Can you tell what the problem might be from this error?

How do I check what the schema name is? the user name is definitely sde.

14 Replies
Highlighted
Esri Frequent Contributor

Based on the error message there appears to be a mismatch of the DB name and schema in SQL Server. Does the username and schema match in SQL Server? i.e. User Name = SDE and Schema = SDE?

You may also want to review this link: How To: Create an SDE schema geodatabase using the Enable Enterprise Geodatabase geoprocessing tool ...   It shows you where to check if the schema/username matches - look at Step 2.

--- George T.
Highlighted
New Contributor II

Yes, they are both sde

Reply
0 Kudos
Highlighted
Occasional Contributor

Hello,

1. Make sure set SQL Server database options READ_COMMITTED_SNAPSHOT and ALLOW_SNAPSHOT_ISOLATION to ON. You can check the two options by right clicking on the database > Properties > Options.

2.You can check the schema of the user by following steps:

In SSMS, Security --> Logins --> Right click on the user --> Properties --> User Mapping --> make user that user name and default schema match.

3. Make sure user have, at a minimum, the following privileges: CREATE FUNCTION, CREATE PROCEDURE, CREATE TABLE, and CREATE VIEW.
----------------------------------------------------------------------
 Set up an enterprise geodatabase in SQL Server
https://desktop.arcgis.com/en/arcmap/latest/manage-data/gdbs-in-sql-server/setup-geodatabase-sqlserv...
 ----------------------------------------------------------------------

Reply
0 Kudos
Highlighted
New Contributor II

Both the username and default schema are sde. And those other options are both set to TRUE. I am told by the SQL server folks that sde is the administrator so it has all those privileges.

Reply
0 Kudos
Highlighted
Occasional Contributor

In SSMS, right click on the database -> properties -> permissions -> click on sde user -> effective and please confirm which permissions are granted.

Reply
0 Kudos
Highlighted
New Contributor II

There is a huge list. I have confirmed the four you mentioned are in the list.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Make sure that they did not give "SYSADMIN" to the SDE user.

--- George T.
Highlighted
New Contributor II

I don't see it on the list. I think I misspoke before, I think sde is the db owner, not "administrator"

Reply
0 Kudos
Highlighted
Occasional Contributor

Please confirm if "sysadmin" fixed server role or db_owner database role is granted to the sde user or not. If yes, then revoke these role and grant CREATE FUNCTION, CREATE PROCEDURE, CREATE TABLE, and CREATE VIEW to the sde user.

Reply
0 Kudos