Issue while creating Enterprise GDB with Postgresql

700
10
06-03-2018 10:46 AM
Highlighted
New Contributor III

Dear Esri Enterprise Geodatabase Team,

I am having an issue in Enabling Enterprise Geodatabase. The architecture is as follows.

We have three VM's.

First VM - ArcGISPro 2.0(Installed Successfully)

Second VM - Postgresql (postgresql-9.5.3-1-windows-x64-------Installed Successfully)

Third VM - Server. (ArcGISServer10.6-------Installed Successfully).

 

Now when I am creating a Enterprise Geodatabase from the First VM where ArcGIS Pro is installed - I am getting an Error saying "Instance not available on Server - Failed to Execute Create Enterprise Geodatabase).

I have copied the Keycodes file generated from Third VM - Server. (ArcGISServer10.6) and has put in the local system.

 

 

How to enable this.

Reply
0 Kudos
10 Replies
Highlighted
Esri Frequent Contributor

Did you update the pg_hba.config file? This file allows the Postgres DB to accept connections from other machines.

Create a geodatabase in PostgreSQL on Windows—Help | ArcGIS Desktop 

You can install PGAdmin or other PG SQL client and try to connect to the DB as the PG Admin?

--- George T.
Highlighted
New Contributor III

Hi Hussain,

I have actually configured Server Correctly in "geodb01b" Vmware.
I have configured Postgresql Properly.
I have given in this statement in geodb01a
host all all all md5 in this path - "C:\Program Files\PostgreSQL\9.5\data"
Pgadmin setup is installed automatically as a part of the Postgresql Installation. I am trying to connect first in this VM before I goto my machine on the Network.
Reply
0 Kudos
Highlighted
Esri Frequent Contributor

I think that may have to do with the DB name. The issue may be with the underscore "_" Here is the note from the help:

Type the database name in lowercase; upper- and mixed-case object names are not supported for geodatabases in PostgreSQL. If you type a database name in upper or mixed case, ArcGIS converts it to lower case.

This is step #5 under "Create a geodatabase" at the link above.

Can you please try and create a default DB called "esritest"? and report the results?

--- George T.
Highlighted
Esri Frequent Contributor

Here is another piece of help doc that supports the "_" not being a good thing:

Database management systems have different definitions of acceptable characters for object names. Most names must begin with a letter and cannot contain spaces, backslashes, or reserved database management system keywords. Some databases allow special characters such as forward slashes (/), underscores (_), dollar signs ($), dashes (-), dots (.), or mixed cases. Sometimes the database allows you to use special characters or reserved keywords, or force mixed, upper-, or lowercase names if you provide the object name enclosed in delimiters, such as double quotation marks.

However, ArcGIS does not delimit object names. Do not create any tables, feature classes, indexes, databases, users*, roles, or other object names that require delimiters if you will be using them with ArcGIS. The object will be created in the database, but you cannot access it from ArcGIS.

Enterprise geodatabase size and name limits—ArcGIS Help | ArcGIS Desktop 

--- George T.
Highlighted
Esri Esteemed Contributor

Underscore should be okay, but ALLCAPS and MixedCase are BAD (with or without underscore).

- V

Highlighted
New Contributor III

Hi Vince,

I tried with all the options by giving lower case only and not any mixed characters - But still it is the same. Please find the below for the same.

Reply
0 Kudos
Highlighted
New Contributor III

Hi George,

I tried with all the options by giving lower case only and not any mixed characters - But still it is the same. Please find the below for the same.

Reply
0 Kudos
Highlighted
Occasional Contributor II

It looks like in the tool inputs you have the default Postgres port 5432 specified as the Instance name input- is this valid per your configuration? There should be no need to specify the port number if Postgres is running on the default port 5432. If you have a running instance / service on the Windows server- try inputting the name of the database instance (might be the server name if you're unsure) and see if that works. Hope this is helpful!

Best,

Rex R

Reply
0 Kudos
Highlighted
New Contributor III

Hi Rex,

Could you Please let me know the Process for the same....

Reply
0 Kudos