How to Configure ArcSDE on PostgreSQL 10 and higher versions

263
2
01-30-2019 01:39 AM
AhsanMukhtar1
New Contributor II

I am using this environment

1- ArcGIS 10.6

2- PostgreSQL 10

3- Windows 10 64 bit

I am trying to create enterprise database using ESRI's Created Enterprise Geodatabase  tool, but i can not do that, the higher version that i found for ST_GEOMETRY is 9.6 available in ArcGIS 10.6. So, is there anyway to configure it with PostgreSQL 10, or do i have to wait for some other release and then might be able to configure it with postgresql 10. 

I have tried using 9.6 libraries, but not been able to run the tool successfully.

Thanks

Reply
0 Kudos
2 Replies
George_Thompson
Esri Frequent Contributor

Look in this location for the libraries: C:\Program Files (x86)\ArcGIS\Desktop10.6\DatabaseSupport\PostgreSQL

I see the Postgres 10 folder.

--- George T.
BirajaNayak
Occasional Contributor III

PostgreSQL 10.3 supported from ArcGIS 10.6.1 onward. Please check the system requirement page as per below:

http://desktop.arcgis.com/en/system-requirements/10.6/database-requirements-postgresql.htm