Select to view content in your preferred language

Enterprise Geodatabase (Postgres) 'RegisterAsVersioned' Error

610
3
03-08-2022 10:22 PM
JohnBrandi
New Contributor

Hi Everyone,

I'm using PostgreSQL/PostGIS to manage an enterprise geodatabase that I'm working on through ArcGIS Pro. In my Postgres database cluster, I have a data creator/loader named "fire_dept" with its own schema of the same name. In that schema is a feature dataset name "f_dispatch" which contains three feature classes.

I had this user upload shapefiles to the Postgres database, then clicked "Register with Geodatabase" on each through a DB connection in ArcGIS Pro, and then moved them into the feature dataset. Now I'm trying to register the feature dataset as versioned and I'm encountering the attached error. It makes no sense because the "fire_dept" user matches the schema name that holds the feature dataset/classes, and "fire_dept" is both a data creator and the owner of the data. 

Might anyone know why this is occurring?  

Thanks in advance!

- John Brandi

Tags (2)
0 Kudos
3 Replies
KimGarbade
Regular Contributor

I'm not seeing the attached error.  Would it be possible to repost it please?

0 Kudos
BaposDo
New Contributor

Can you explain a little bit more it will be easy for me to give an answer correctly.

0 Kudos
KimGarbade
Regular Contributor

In the original post you mention "Now I'm trying to register the feature dataset as versioned and I'm encountering the attached error", but I don't see the attachment containing the error message.

0 Kudos