Cannot able to upgrade arcgis server 10.0 to 10.3?

2071
12
02-10-2016 05:21 AM
Highlighted
New Contributor III

Hi All,

       I am trying to upgarde from arcgis server 10.0 to 10.3,

While doing this i am getting error like below, Please help me on this issue.

[Wed Feb 10 18:25:51 2016] DB_open_instance()::db_connect (OCI8) error: 12560

[Wed Feb 10 18:25:51 2016] Error: Underlying DBMS error (-51).

[Wed Feb 10 18:25:51 2016] Error: DB_arcsde_setup: Unable to connect

[Wed Feb 10 18:25:51 2016] ORA-12560: TNS:protocol adapter error

[Wed Feb 10 18:25:51 2016] ERROR installing/upgrading ArcSDE, Error = -51

Here i have both oracle 64-bit client and 32-bit oracle client and i am able connect from ArcCatalog,

But when i tried to upgarde it is giving this error? Please please help me on this issue

Reply
0 Kudos
12 Replies
Highlighted
Regular Contributor III

Are you upgrading your SDE Oracle geodatabase?

What was the Oracle Database version at 10.0 (Example: Oracle 10.2.0.1) and what is the version of the Oracle database you are using right now while upgrading to 10.3?

Reply
0 Kudos
Highlighted
New Contributor III

Yes i am trying to upgrade sde 10.0 oracle geodatabase

In one system  i have installed arcgis server 10.3 and another syatem contains oracle geodatabase 10.0.

here i have installed both oracle 64bit 11g client and 32bit 11g client, And oracle geodatabase 10.0 has same vesrion.

I am connecting to database through ArcCatalog 10.3 like this

(//xxxx:1521/orcl, username:sde, password:sde)

it is successfully connecting to database and Pre-Requisite check is succeeded , But upgradation fails.

[Thu Feb 11 13:14:51 2016] DB_open_instance()::db_connect (OCI8) error: 12560

[Thu Feb 11 13:14:51 2016] Error: Underlying DBMS error (-51).

[Thu Feb 11 13:14:51 2016] Error: DB_arcsde_setup: Unable to connect

[Thu Feb 11 13:14:51 2016] ORA-12560: TNS:protocol adapter error

[Thu Feb 11 13:14:51 2016] ERROR installing/upgrading ArcSDE, Error = -51

Reply
0 Kudos
Highlighted
Regular Contributor III

You did not provide all the details that were requested.

What was the DBMS version for the 10.0 gdb? Has that been upgraded to a higher DBMS version? What is it now?

Reply
0 Kudos
Highlighted
New Contributor III

DBMS version of 10.0 gdb is 11.2.0.1.0 and the version of the Oracle database now using is same 11.2.0.1.0

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Please clarify what you are attempting by describing the steps preceding this error, and what command produced the error.

It appears you have made changes to the database and have not reconfigured it correctly so that even a tnsping would succeeed.  If Oracle has no connectivity, there really isn't anything ArcGIS can do.

- V

Reply
0 Kudos
Highlighted
New Contributor III

I am trying to upgrade sde 10.0 oracle geodatabase.

In one system  i have installed arcgis server 10.3 and another syatem contains oracle geodatabase 10.0.

here i have installed both oracle 64bit 11g client and 32bit 11g client, And oracle geodatabase 10.0 has same vesrion.

I am connecting to database through ArcCatalog 10.3 like this

(//xxxx:1521/orcl, username:sde, password:sde)

it is successfully connecting to database and Pre-Requisite check is succeeded , But upgradation fails.

[Thu Feb 11 13:14:51 2016] DB_open_instance()::db_connect (OCI8) error: 12560

[Thu Feb 11 13:14:51 2016] Error: Underlying DBMS error (-51).

[Thu Feb 11 13:14:51 2016] Error: DB_arcsde_setup: Unable to connect

[Thu Feb 11 13:14:51 2016] ORA-12560: TNS:protocol adapter error

[Thu Feb 11 13:14:51 2016] ERROR installing/upgrading ArcSDE, Error = -51

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

We need details to understand what may be going on.

Please provide:

  • The exact version (five digits - e.g. 10.2.0.4.7) of Oracle installed on the original enterprise geodatabase
  • The exact version (five digits) of the Oracle client installs
  • Whether the database has been upgraded or transferred to a different server (and if so, the exact version of that database)
  • The exact PATH variable contents
  • Whether you have 64-bit background geoprocessing installed
  • Whether you have the background geoprocessing opption enabled

Please do not ever post passwords on the Internet (and never make the SDE user password 'sde' -- this is a huge vulnerability that threatens your entire geodatabase).

- V

Reply
0 Kudos
Highlighted
New Contributor III

Answers to your questions

1) The exact version (five digits - e.g. 10.2.0.4.7) of Oracle installed on the original enterprise geodatabase = 11.2.0.1.0

2) The exact version (five digits) of the Oracle client installs = 11.2.0.1.0

3)  The 10.0 arsde oracle database is in one system and now i have installed arcgis server 10.3 in another system with oracle clients with same version

4) The exact PATH variable contents = set to oracle 32 bit client so that i can connect to arcgis server and register the database there.

6) background geoprocessing opption enabled = yes

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Still need an answer to Q5, to see if A6 is significant, but ArcGIS 10.3 is only supported on Oracle 11.2.0.3.x and higher​ (10.4 will up that to 11.2.0.4.x).

- V

Reply
0 Kudos