How to add value to area of raster bound by polygon?

486
7
Jump to solution
07-31-2020 07:03 AM
ArranClarke
New Contributor

I have a raster showing the topography of  an area. I need to add 0.1 m to an area of the raster. I have tried making a new raster of the area that I need to add too, giving it a value of 0.1 and then adding them together however this reduces the siize of the raster to just the area that I have added to.

0 Kudos
1 Solution

Accepted Solutions
DavidPike
MVP Frequent Contributor

try right-click->data->export then choose extent of display (zoom out to cover all features), reclassify nodata to 0 then try it with tht output raster.

View solution in original post

0 Kudos
7 Replies
DavidPike
MVP Frequent Contributor

are you trying to add 0.1 to just one side? is your cell size 0.1m? why a cell value of 0.1 for the raster? What is his raster?, and why do you need to do this?

Check the environments are set to Union of Inputs when you do the Raster Calculator.

0 Kudos
ArranClarke
New Contributor

The raster is the top elevation of a clay layer which I am using in a groundwater model. In the system I am modeling the clay is below the water table except for a part in the middle where the elevation is higher. I wish to increase the elevation of the area that is supposed to be the part above the water table. I have a shapefile defining this area. I would like to increase the elevation in this area by 0.1 m.

0 Kudos
DavidPike
MVP Frequent Contributor

OK.  You've probably got a raster with 0.1 values for the shapefile area but surrounded by NoData values for the rest of the extent.  When you add the 2 rasters together, the NoData wipes out the other raster values.

Ensure NoData values are set to zero in your smaller-area raster using the Recalssify tool, then add them together in raster calculator ensuing that the processing extent is set to union of inputs or another appropriate extent.

0 Kudos
ArranClarke
New Contributor

That has almost worked however as the +0.1 area is so much smaller than the elevation raster it still crops the raster to the max E-W and N-S extent of the +0.1 area. Is there a way to increase the size of the +0.1 raster so it is the same size as the clay top raster? I've tried increasing the extent in it's properties however this makes no difference when I reclassify it. 

0 Kudos
DavidPike
MVP Frequent Contributor

Seems very much like a processing extent issue.  Are you using the processing extent I suggested?

0 Kudos
ArranClarke
New Contributor

I've tried using both union of inputs and setting the extent to the size of the clay elevation raster. The output is still cropped surrounded by NoData for the extent of the clay elevation raster.

0 Kudos
DavidPike
MVP Frequent Contributor

try right-click->data->export then choose extent of display (zoom out to cover all features), reclassify nodata to 0 then try it with tht output raster.

0 Kudos