Experience Builder Dev Edition Installation fails

388
1
Jump to solution
05-16-2023 04:33 AM
RiccardoKlinger
Occasional Contributor

I am trying to install the experience builder dev edition on my Windows machine. Unfortunately this fails with a quite generic error:

 

1819 timing command:i Completed in 6584ms
1820 verbose stack TypeError [ERR_INVALID_URL]: Invalid URL
1820 verbose stack     at new NodeError (node:internal/errors:372:5)
1820 verbose stack     at URL.onParseError (node:internal/url:553:9)
1820 verbose stack     at new URL (node:internal/url:629:5)
1820 verbose stack     at getProxyUri (C:\Program Files\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:160:53)
1820 verbose stack     at getAgent (C:\Program Files\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:21:17)
1820 verbose stack     at remoteFetch (C:\Program Files\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\remote.js:31:17)
1820 verbose stack     at cacheFetch (C:\Program Files\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\cache\index.js:16:28)
1820 verbose stack     at async fetch (C:\Program Files\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\fetch.js:98:7)
1820 verbose stack     at async RegistryFetcher.packument (C:\Program Files\nodejs\node_modules\npm\node_modules\pacote\lib\registry.js:92:19)
1820 verbose stack     at async RegistryFetcher.manifest (C:\Program Files\nodejs\node_modules\npm\node_modules\pacote\lib\registry.js:124:23)
1821 verbose cwd C:\work\arcgis-experience-builder-1.11\ArcGISExperienceBuilder\server
1822 verbose Windows_NT 10.0.19044
1823 verbose node v16.16.0
1824 verbose npm  v8.11.0
1825 error code ERR_INVALID_URL
1826 error Invalid URL
1827 verbose exit 1
 
I am also running and developing other react applications with the same proxy configuration without any issues.
I am looking forward any ideas to fix this. 
1 Solution

Accepted Solutions
RiccardoKlinger
Occasional Contributor

always make sure to use the correct .npmrc file and the syntax. this will overrule any "npm config set proxy xx.xx.xx.xx:port" command. 

the file should look like this:

 

proxy="http://NOTE.IP.HERE.PLEASE:PORT"
https-proxy="https://NOTE.IP.HERE.PLEASE:PORT"
strict-ssl=false

 

View solution in original post

0 Kudos
1 Reply
RiccardoKlinger
Occasional Contributor

always make sure to use the correct .npmrc file and the syntax. this will overrule any "npm config set proxy xx.xx.xx.xx:port" command. 

the file should look like this:

 

proxy="http://NOTE.IP.HERE.PLEASE:PORT"
https-proxy="https://NOTE.IP.HERE.PLEASE:PORT"
strict-ssl=false

 

0 Kudos