ArcGIS Server (non-GUI Linux) Licence Authorization Fails?

3683
6
12-16-2015 01:13 AM
YucelTepekoy
New Contributor

I have a Ubuntu 14.x server on Cloud and I installed ArcGIS for Server Enterprise (Linux) 10.3.1. Since it is non-gui environment I did it on Terminal.

The product I downloaded: ArcGIS for Server Enterprise (Linux) 10.3.1. 
The provisioning file I created is for: ArcGIS for Server Advanced Enterprise 10 - 10.3.1

During the authorization step, it warned me that my provisioning file (.prvc) is not valid. Thus, I tried arcgis/server/tools/authorizationSoftware to authorize my software using following commands with also failure.

./authorizationSoftware -f licence.prvc 
./authorizationSoftware -f licence.prvc -e myemail@domain.com

The licence is fresh and never installed to somewhere else. I couldn't get support from esri.

My provisioning file looks like this:

//Provision Provision ID=XXXXXX-XXXX-XXXX-XXXXXXXXXXXXX
Comment=   // User Information
First Name=XXXX
Last Name=XXXX
Organization=XXXXXXXX
Department=
Email=XXXXXXXXX
Address 1=XXXXXXXXXXXXXXX
City=XXXXX/XXXX
State/Province=XX
Location
Code=XX L
ocation=X
Zip/Postal Code=XXXXX
Phone Number=XXXXXXXXXXX 
// Features and authorization numbers
ArcGIS Server=ECP NUMBER
0 Kudos
6 Replies
YucelTepekoy
New Contributor

Software authorization failed. Please make sure your authorization file is valid and try again.

0 Kudos
CelineKayitana
New Contributor

Hello  Yucel,

Did you find a solution? I am also facing the same issue.

Best,

Celine.

0 Kudos
GriffinMorgan1
Esri Contributor

Celine,

The original post was in reference to installing ArcGIS Server 10.3.1 on Ubuntu, which wasn't supported at the time. What version are you using and on what OS?

0 Kudos
CelineKayitana
New Contributor

Hello Griffin,

I am back after that long.

I am using ArcGIS Enterprise 10.6.1 on Linux. Redhat

That time it finally work, but I am facing the same issue again, where the portal license expired, and I am trying to re authorize with a new .prvc license file(with new ECP code)

However,

when running /home/user/arcgis/portal/tools/authorizesoftware -f license.prvc (or -f license.prvc -e email) i get the error saying Error message

when I try to authorize it with a .json file for version 10.7 though my portal version is 10.6.1 it doesn't return any error but shows me the expiration date of the previous ecp file.

Any help would be so much appreciated.

0 Kudos
AmnoyAm
Esri Contributor

Celine,

Are you working with Esri Tech Support by any chance.  I would like to take a look at the provisioning file or at least the ECP code you're using to authorize.  It would be easier and safer to send the information through Tech Support.  

0 Kudos
CelineKayitana
New Contributor

Thank you Amnoy,

We finally tried to use an .ecp file, where we converted the .prvc file into a .ecp file using the Secure Site Operations from myEsri and it worked. It s very strange but we are greatful that it worked.

Thank you,

Celine.

0 Kudos