Unable to access the SQL database with sa,

597
5
Jump to solution
08-11-2014 10:56 PM
Highlighted
Honored Contributor

Unable to access the SQL database with sa,

I couldn’t figure out why I’m not able any longer to access my SQL database with sa knowing that the password is not changed and the option of expiration is not check.

Clip_484.jpg

Clip_485.jpg

Clip_486.jpg

I tried to access it with other user (montaser) and it works fine!

Clip_487.jpg

Is there any chance that the password of the sa is change accidentally?

What other issues should I consider?

Is there any way to change the password of the sa?

Thank you

Best

Jamal

1 Solution

Accepted Solutions
Highlighted
Regular Contributor III

jamal.PNG

Uncheck those two options and try again.

View solution in original post

5 Replies
Highlighted
New Contributor II

Are you able to log into SQL MS with the SA account?  If so then your password is not the issue.  If not then obviously the password was changed and unless you have another account with SysAdmin then I don't think you can change it.  In the event that you cannot determine the password nor the ability to change it you can try the back door mentioned below.

SQL Server lets any member of a Local Administrators group connect to SQL Server with SYSADMIN privileges.

http://technet.microsoft.com/en-us/magazine/jj853293.aspx 

Highlighted
Honored Contributor

Many thanks Scott,

I got a help from SQL database expert and he could resolve the issue (restoring the password of the Sa). I’m not sure which method he sued.

Now, I wanted to change the password of the sa to ensure better security but I got the message below

Clip_197.jpg

Clip_198.jpg

What might be the issue here?

Reply
0 Kudos
Highlighted
Regular Contributor III

jamal.PNG

Uncheck those two options and try again.

View solution in original post

Highlighted
Honored Contributor

Thank you very much Asrujit for the help. It works like a charm

Clip_200.jpg

Best

Jamal

Reply
0 Kudos
Highlighted
New Contributor II

This is because the account has picked up either local or domain policies.  You can change this policy by specifying CHECK_POLICY = OFF, make the change and then turn this back on.