simple range domain does not work

1045
3
Jump to solution
05-22-2014 06:01 AM
Highlighted
Occasional Contributor
Two of us gis guys have tried to create a simple range domain, 10-20. We've tried many variations and the field, in the domain-enabled feature class, continues to allow us to enter numbers outside this range, without the error message. I'd like to list my steps in hopes someone can see what we are doing wrong. 

I entered "RangeDomain"  into the first row of the personal geo database domain properties - entered a description - set the field type to long integer - entered the min  value =10 - entered the max value= 20 - I left split and merge set to "default" - I created a feature class, within the same geo database -  I created a field, "range1" - I set the field properties: format= long integer and selected "RangeDomain" off of the domain pick list - I start editing - I enter a value of 1 into the field and the field accepts it without warning.
Ken
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Frequent Contributor
Ken - as you noticed, range domains do not have automatic validation.  This is by design.  To validate range domains, one must select some or all the features in the feature class and then select Validate Features on the Editor dropdown on the Editor toolbar.

A possible workaround (and it only works in the attribute table view not the Attribute Editor) - "In order to warn the user when they are editing a table directly (for feature classes) you can check the 'Automatically validate records when editing' on the Tools | Options | Tables dialog in ArcMap.  After each edit on a table cell, validation is run and the user is warned each time they edit a value that is not allowed by domains. NOTE: Editing done via the field calcuator is done outside an edit session. Validation can only be triggered inside an edit session. - See more at: http://ideas.arcgis.com/ideaView?id=08730000000bn9XAAQ#comments"

Good luck!

Regards,

Robert LeClair
Esri-Denver

View solution in original post

Reply
0 Kudos
3 Replies
Highlighted
Esri Frequent Contributor
Ken - as you noticed, range domains do not have automatic validation.  This is by design.  To validate range domains, one must select some or all the features in the feature class and then select Validate Features on the Editor dropdown on the Editor toolbar.

A possible workaround (and it only works in the attribute table view not the Attribute Editor) - "In order to warn the user when they are editing a table directly (for feature classes) you can check the 'Automatically validate records when editing' on the Tools | Options | Tables dialog in ArcMap.  After each edit on a table cell, validation is run and the user is warned each time they edit a value that is not allowed by domains. NOTE: Editing done via the field calcuator is done outside an edit session. Validation can only be triggered inside an edit session. - See more at: http://ideas.arcgis.com/ideaView?id=08730000000bn9XAAQ#comments"

Good luck!

Regards,

Robert LeClair
Esri-Denver

View solution in original post

Reply
0 Kudos
Highlighted
Occasional Contributor
Robert,
  Thank you so much for your thorough and helpful answer. Both of us had read up on it, but missed the point that validation happens in a diff, more manual, way than for coded value domains, where we get a pick list of allowable choices. With your help, we are pleased to be able to set the option for automatic validation, via: Customize - arc map options - check the box for "auto validate records when editing" and then get the warning message when we enter a number outside of our range.  Only in an editing session.

We are really grateful for your help.
Ken
Reply
0 Kudos
Highlighted
Esri Frequent Contributor
You're quite welcome Ken - enjoy your weekend.
Reply
0 Kudos