Problem generating schematic from geodatabase feature class

1906
4
04-25-2016 07:02 AM
Highlighted
New Contributor

Hi.  I'm trying to get started generating schematics from a simple geodatabase line feature class but having problems.  I've loaded the feature class into my MXD and then selected "generate new schematic diagram" from the Schematic toolbar. However the "Generate Diagram From" dropdown is blank and I can't select the feature class.  Any idea what I'm doing wrong?

Reply
0 Kudos
4 Replies
Highlighted
MVP Esteemed Contributor
Reply
0 Kudos
Highlighted
New Contributor

Hi

It’s a very basic feature class of rail links so I guess that’s a network dataset??

Eric

Eric Armitage

Data Analyst – Schematic Network

Asset Information: to inspire & enable through the power of data

First Floor, Willen, The Quadrant MK, Elder Gate, Central Milton Keynes, MK9 1EN

T: 01908 783269

E: eric.armitage@networkrail.co.uk<mailto:eric.armitage@networkrail.co.uk>

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

it is just a polyline featureclass, unless you make it something different

What are geometric networks?—Help | ArcGIS for Desktop

What is a network dataset?—Help | ArcGIS for Desktop

Reply
0 Kudos
Highlighted
New Contributor

So I have to create a network from the featureclass using the following

1. Right-click the feature dataset that will contain the network.

2. Point to New.

3. Click Geometric Network

So I’ve created a new schematic dataset in the gdb but when I right click on it then “new” I only see “Schematic Folder”. I don’t seem to have an option to create the Geometric Network??

Reply
0 Kudos