Lesson Learned: Cache job distributed over multiple machines - FAIL!

1524
2
07-11-2014 08:43 AM
JamieHammermann
New Contributor III

I attempted to run a cache over 2 machines on the default cluster.

Using ArcGIS 10.2.2.

My scale levels were 0-12.

Caching ran fine on levels 0, 4, 8, & 11. 

No errors were thrown, but Empty tiles were created in the rest of the levels.

Anyone have success caching over multiple machines? 

0 Kudos
2 Replies
MichaelVolz
Esteemed Contributor

Jamie:

Did you ever attempt to run a cache over 2 machines in an earlier AGS environment?  I ask because other AGS users at v10.2.2 were having cache issues which did not occur in an earlier version such as v10.0.

Although I did not create the caches myself, 5 cache layers were successfully created in my v10.0 production environment which consists of 2 load-balanced ArcGIS Server servers.

JamieHammermann
New Contributor III

I did not try this in an earlier version.  Using multiple machines in the 10.1 lead to serious performance issues (from what I'm told), so I waited until now to try it in 10.2.

I'm reluctant to upgrade other servers to 10.2 with all the issues I'm seeing on my test machines.  I'm actually getting more failures with cache on 10.2 than 10.1.

As an aside, I've also tested map service response times with 2 machines on a site vs. one machine using 10.2.2.  It seems that using 2 machines costs an extra 10-25% in latency (on my network, anyways).  So while a multi-machine site may be able to handle a greater volume of requests, performance takes a hit.

0 Kudos