I don't see the XY fields in "Dsiplay XY"

520
12
Jump to solution
12-07-2016 05:07 AM
Highlighted
New Contributor II

I am unable to display the coordinates XY since I do not visualise the fields containing them into the drop-down menu of the "Display XY" or Make XY Event layer. The fields are perfectly fine in the tables. There are no spaces, blanks. Tried imported the files as Excel, CSV, DBF. 

Ideas on why is this happening? Solutions? Thanks in advance!

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Esteemed Contributor

Check the original text version.  Why are you using some Aoi_ID for the X field?  that should be a longitude field.

View solution in original post

12 Replies
Highlighted
MVP Frequent Contributor

Can you show a picture of your data here, or post some example.

It is likely that they are being interpreted as text fields rather than as numbers.

Reply
0 Kudos
Highlighted
New Contributor II

This is how my data looks in excel.

Reply
0 Kudos
Highlighted
Occasional Contributor II

May have better luck bringing in the data as a CSV instead of an excel format.

Highlighted
New Contributor II

CSV had the same issue

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

What are your regional settings for the decimal separator? "." or ","?

Reply
0 Kudos
Highlighted
Occasional Contributor II

Bring it in to arcmap, save as dbf, then check it’s field properties in the dbf. I would bet they are string.

Highlighted
Occasional Contributor II

Check the field properties, very likely they are string for coordinates they need to be double. Might have to add new fields as doubles and calc the fields from the old string fields. Also check for things in the fields like commas as the software uses this to define them as strings.

Highlighted
New Contributor II

You are right! They are strings. I will have to convert them to doubles. Let's see how that works! Suggestions?

Reply
0 Kudos
Highlighted
Occasional Contributor II

Bring in the excel table to ArcMap, export it out as a dbf or GeoDatabase table, you have to export as ArcMap will not edit excel. Open the new table add in 2 new fields for the lat/Longs, define as double. Using the field calculator calculate their values to be the old lat/long fields, this should bring them over and save them as double.Once done, then right click on table, add X,Y enent and you should see the new fields. Make sure Lat is Y and Long is Z. Under projection, set it to 4326 / WGS 84 if it’s really Lat/Longs. The points should show up in the right place, if so then export out as Shapefile or FeatureClass and your done.