How to change a field-type of a ahape-field column

1108
3
Jump to solution
02-03-2017 03:42 AM
Highlighted
New Contributor III

Hallo all together,

I made a mistake while adding a new field to my shape file. I used the wrong field type and now, I don’t know how to change the field type or delete the whole field.

Dobble-click on the shape in the catalogue: no possibilities to change

Right-click on the layer in the content/ properties: the layer details are grey and can’t be changed.

I hope in this forum is anybody who can help me. Thank you so much and sorry for my poor English.

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Regular Contributor II

Open Arc Toolbox > Data Management Tools > Fields > then use Alter Field. ( for empty table)

Alter Field—Help | ArcGIS Desktop

Also, If you have ArcGIS Before 10.3 . You Can use Delete Field Delete Field—Help | ArcGIS for Desktop  , Then Use Add Field.  Add Field—Help | ArcGIS for Desktop 

View solution in original post

3 Replies
Highlighted
Occasional Contributor II

To add a field  do this open ArcMap > open Attribute Table > from table options select "Add Field" this will allow you to define your field.

To delete a field open ArcMap > open Attribute Table > right click on field to be deleted an choose "Delete Field"

both of these actions need to be done outside of a edit session.  If you need to copy data over you will want to create the new field first.  If you want to reuse the field name you will need to delete the existing field first.

Highlighted
Regular Contributor II

Open Arc Toolbox > Data Management Tools > Fields > then use Alter Field. ( for empty table)

Alter Field—Help | ArcGIS Desktop

Also, If you have ArcGIS Before 10.3 . You Can use Delete Field Delete Field—Help | ArcGIS for Desktop  , Then Use Add Field.  Add Field—Help | ArcGIS for Desktop 

View solution in original post

Highlighted
New Contributor III

Dear Christoher

dear Abdullah,

 

At first thank you so much for your support. I tried Christopher’s advice at first, but nothing happens. I can add the field like you mentioned, but if I click "Delete Field" there is no reaction. I don’t know why, but it doesn’t matters, because the way of Abdullah works really fine!!! Thanks a lot, both of you.

Best wishes, Andreas

Reply
0 Kudos