Error trying to Register as Versioned (Merged threads)

2915
14
05-20-2014 10:46 AM
Highlighted
New Contributor III
I am having troubling getting my database to register as 'Versioned." I added a feature class to the feature dataset but ended up having to delete it now I can not re-register the feature class as versioned, any thoughts?

Desktop Version 10.1, WIndows 7
Reply
0 Kudos
14 Replies
Highlighted
Esri Esteemed Contributor
How did you drop the previous table?  With ArcGIS or from the database?

- V
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: zydeco42

How did you drop the previous table?  With ArcGIS or from the database?

- V


I deleted it from the database/feature dataset in ArcCatalog by right-clicking the feature class and selecting 'Delete.' Is that the correct way?
Reply
0 Kudos
Highlighted
New Contributor III
This is the message I receive in ArcMap when I try to start editing.
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: zydeco42

I am having troubling getting my database to register as 'Versioned." I added a feature class to the feature dataset but ended up having to delete it now I can not re-register the feature class as versioned, any thoughts?

I deleted the feature class(es) from the database/feature dataset in ArcCatalog by right-clicking the feature class and selecting 'Delete.' Is that the correct way?

Desktop Version 10.1, WIndows 7

Thanks
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: asrujit

Need some clarifications:

1. Was the Feature dataset already Versioned before you added the new FC(s)?

2. Did you Register as Versioned the dataset after adding the new FC(s)?

Sounds very basic, but close all the interfaces. reopen and then try the process...
Reply
0 Kudos
Highlighted
Regular Contributor III
This is the message I receive in ArcMap when I try to start editing.


This error usually points to a permission issue.

Try to add the entire Feature dataset in a new ArcMap session and try to start editing. let us know if you receive any errors in this process.
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: zydeco42

Need some clarifications:

1. Was the Feature dataset already Versioned before you added the new FC(s)?

2. Did you Register as Versioned the dataset after adding the new FC(s)?

Sounds very basic, but close all the interfaces. reopen and then try the process...


1. Yes the feature dataset was already versioned before adding the new feature class(es)

2. No I did not register as versioned prior to adding the new feature class(es), it was already versioned. I did however try to Version once I created the feature class(es). The problem occurred when I deleted the newly created feature class(es), I am now unable to preform any edits and cannot reconcile.

I have closed and open ArcMap & ArcCatalog several times, it did not solve the problem. The database lives on my supervisors machine and that has not been rebooted yet.
Reply
0 Kudos
Highlighted
New Contributor III
This error usually points to a permission issue.

Try to add the entire Feature dataset in a new ArcMap session and try to start editing. let us know if you receive any errors in this process.


I just tried editing in a new ArcMap session still getting the same error
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: solxenos

Do you have a map service using the SDE database?
Reply
0 Kudos