Error loading GML file

926
7
09-13-2011 10:10 PM
HaydenFoley
New Contributor III
Hi There,

I have the Data Interoperability extension installed and can perform a successful 'Quick Export' to GML and then import back again the exported file into ArcMap.

However, I have an externally sourced GML file that simply will not load and returns the error "Error when writing schema: A unique destination feature type name can not be generated for.."

Please provide advice on how I can load  up the below. Does it need to be reformated to a later version of GML. If so what would the new format look like applied to the example below?

Any help greatly appreciated

<?xml version='1.0' encoding='UTF-8'?>
<schema
xmlns='http://www.w3.org/2000/10/XMLSchema'
xmlns:gml='http://www.opengis.net/gml'
xmlns:xlink='http://www.w3.org/1999/xlink'
xmlns:xsi='http://www.w3.org/2000/10/XMLSchema-instance'
xsi:schemaLocation='http://www.opengis.net/gml/feature.xsd'>
<gml:Polygon srsName='http://www.opengis.net/gml/srs/epsg.xml#28355'>
<gml:outerBoundaryIs>
<gml:LinearRing>
<gml:coord><gml:X>505461.452639567</gml:X><gml:Y>5404659.39500733</gml:Y></gml:coord>
<gml:coord><gml:X>505478.218825224</gml:X><gml:Y>5404650.16791261</gml:Y></gml:coord>
<gml:coord><gml:X>505418.476206284</gml:X><gml:Y>5404545.29881424</gml:Y></gml:coord>
<gml:coord><gml:X>505385.948338288</gml:X><gml:Y>5404567.63763573</gml:Y></gml:coord>
<gml:coord><gml:X>505437.142484404</gml:X><gml:Y>5404623.22069171</gml:Y></gml:coord>
<gml:coord><gml:X>505461.452639567</gml:X><gml:Y>5404659.39500733</gml:Y></gml:coord>
</gml:LinearRing>
</gml:outerBoundaryIs>
</gml:Polygon>
</schema>
0 Kudos
7 Replies
MitaHajirakar
New Contributor
Hi Hayden,

For some reason the DI is unable to generate unique layers with your GML file.  I'd need to take a look at the GML file to understand why.  Are you able to pass it on so I can take a look?

Kind regards,
Mita Hajirakar
Safe Software, Inc.
0 Kudos
AliceShepherd
New Contributor II
Hi,

I am having the same problem loading an externally sourced gml file using the quick import tool.  Also get the error message "Error when writing schema: A unique destination feature type name can not be generated for ". Did you find a solution to this problem?

Alice
0 Kudos
MitaHajirakar
New Contributor
Hi Alice,

Again I'd need to take a look at your GML file.  Are you able to send it to me?  What version of ArcGIS are you using?

Kind regards,
Mita Hajirakar
Safe Software, Inc.
0 Kudos
BradHuff
New Contributor
Same problem, has a fix been found? Thanks
0 Kudos
MitaHajirakar
New Contributor
Hi there,

I'd need to take a look at your data and try to reproduce the problem so I can investigate further - are you able to send it to me?

Thanks,
Mita Hajirakar
Safe Software, Inc.
0 Kudos
HarmenKampinga
New Contributor III
it's good to see that individual issues are resolved, but what is the true solution to this problem I'm facing too?
0 Kudos
BruceHarold
Esri Regular Contributor
Hi All

When looking at these GML issues we find that many files are not valid GML.  There can be many reasons, for example:

http://fmepedia.safe.com/articles/Error_Unexpected_Behavior/GML-geometries-not-read

You can test any GML/XML with the XMLValidator. You can test GML using the schemas that come with Data Interop in: C:\Program Files (x86)\Esri\Data Interoperability (x86)\xml\schemas\schemas.zip\gml

If you want to test the validity of your files please open a support incident and we'll take a look.

Regards
0 Kudos