Create Enterprise GeoDatabase Error on PostGreSQL

1826
11
05-21-2017 09:05 PM
SignalGroup
New Contributor

I am running Create Enterprise GeoDatabase tool on PostgreSQL Database on windows ,this tool is throwing above error

0 Kudos
11 Replies
JayantaPoddar
MVP Esteemed Contributor

What is the version of PostgreSQL? PostgreSQL database requirements for ArcGIS 10.4.x



Think Location
0 Kudos
SignalGroup
New Contributor

I am using Postgres 9.4.11(64bit) , PostGIS 2.3.2 (64bit) , ArcGIS 10.4 ..

Windows 8 64Bit OS.

0 Kudos
ChrisCatania
Community Team

Hi Signal Group team - Thanks for asking your questions and welcome to the GeoNet community! I wanted to let you know that we're moving your question to the Managing Data space so our Esri and user subject matter experts can further help answer this and future questions.  So you're aware on how and where to post your questions, here's a few quick tips and reminders:

  1. First, use the GeoNet search (top right corner by your profile icon) to search and see if your question has already by asked/answered previously.
  2. If not, than we suggest reviewing the GeoNet Community Structure, to find the most relevant space to post your question. 
  3. The GeoNet GeoNet Help group is for questions and tips on how to use the GeoNet community platform not the Esri ArcGIS platform. Following steps 1 & 2 above will give you the best results for getting Esri product questions answered.
  4. This GeoNet 101 "How to Ask Questions on GeoNet" post is also a helpful guide to asking questions: https://community.esri.com/community/help-and-feedback/blog/2016/08/15/community-news-and-tips-how-t...

 

Thanks again for contributing and I hope this helps and let us know if you have any questions.

Esri Community Strategist
0 Kudos
George_Thompson
Esri Frequent Contributor
0 Kudos
VinceAngelo
Esri Esteemed Contributor

It's always critical to specify, in  the question:

  • The exact release of the database to which you are connecting, and
  • The exact release of ArcGIS which is being used to connect.

The error message implies that your database is incompatible with your Desktop.

- V

SignalGroup
New Contributor

I am using Postgres 9.4.11(64bit) , PostGIS 2.3.2 (64bit) , ArcGIS 10.4 ..

Windows 8 64Bit OS.

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

Well from the System Requirements page PostgreSQL database requirements for ArcGIS 10.4.x—System Requirements | ArcGIS Desktop , it seems that the PostGIS 2.3.2 is not supported with 10.4.x yet.

Can you try with PostGIS 2.2 and check...

SignalGroup
New Contributor

Thanks for Solution .

It is working now ..One Problem is that we should connect the DB using SDE User ,then run this particular tool on that connection ,it works.

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

That is because the PostgreSQL Enterprise Geodatabase System Table needs to be created under the SDE Schema.

Create a geodatabase in PostgreSQL on Windows—Help | ArcGIS Desktop 

Check the "Create a geodatabase" part in the above link..