Connection ArcSDE failed to connect to database

2738
3
02-08-2011 09:52 AM
Highlighted
Occasional Contributor
Hi,

We are having a lots of connections problem with this error :

Failed to conect to database.
Maximun number of connections to instance exceeded[Connection failed when attempting to connect using a 9.3.1 direct connect driver to a 9.2 geodatabase. Missing suitable direct connection driver for this connection type. Please install the 9.2 direct connection driver. ArcSde Direct Connect driver release = 93004; ArcSde database instance release - 92011; ArcSde low release for instance - 92005]


The problem can happen twice a day and came back two week laters !! It's always random but most of the time it's work.

Is anybody have a solution to fix this error ??

Thanks

Pierre
0 Kudos
3 Replies
Highlighted
Occasional Contributor III
Pi-Hellz,

The first part of the message indicates that more people are trying to connect to the geodatabase than you have set to allow. There is a setting in the server_config table, CONNECTIONS, that determines how many simultaneous connections you can have to the geodatabase.  By default, this number is 48.  If you need to increase that number, use the sdeconfig administration command utility with the alter operation to set it to a higher number; for example:

sdeconfig -o alter -v CONNECTIONS=75 -u sde -D mydatabase -i sde:sqlserver:myinstance

(http://help.arcgis.com/en/geodatabase/10.0/admin_cmds/Support_files/admincmdref.htm)

The rest of the message makes it sound like your client doesn't have the direct-connect driver it needs.  But if it works sometimes and not others, that doesn't make sense.  If upping the connection property doesn't help, please contact Esri support for assistance.

Regards,

Kim
0 Kudos
Highlighted
New Contributor
Is there anyway of finding out, using the command line, the current allocated connections?

Pi-Hellz,

The first part of the message indicates that more people are trying to connect to the geodatabase than you have set to allow. There is a setting in the server_config table, CONNECTIONS, that determines how many simultaneous connections you can have to the geodatabase.  By default, this number is 48.  If you need to increase that number, use the sdeconfig administration command utility with the alter operation to set it to a higher number; for example:

sdeconfig -o alter -v CONNECTIONS=75 -u sde -D mydatabase -i sde:sqlserver:myinstance

(http://help.arcgis.com/en/geodatabase/10.0/admin_cmds/Support_files/admincmdref.htm)

The rest of the message makes it sound like your client doesn't have the direct-connect driver it needs.  But if it works sometimes and not others, that doesn't make sense.  If upping the connection property doesn't help, please contact Esri support for assistance.

Regards,

Kim
0 Kudos
Highlighted
Esri Esteemed Contributor
The current setting of the CONNECTIONS parameter is returned by:

sdeconfig -o list -P CONNECTIONS -u ...

The current number of active connections is determined by:

sdemon -o info -I USERS -s server -i port

(if the service is running) or by doing a "SELECT count(*) from sde_process_information"
("process_information" on Oracle).

- V
0 Kudos