Connect to SQL server

3706
7
Jump to solution
02-01-2015 12:09 PM
Highlighted
New Contributor II

Hi dears!

I need to help!

My OS is Windows 8 32 bit, ArcGIS 10.2.2 and I installed "ArcSDE for Microsoft SQL Server Express". But when I want to built a Geogatabase on my Database Server I will see this error message!(The picture)

And I also couldn't connect to PostgreSQL 9.2!

Please help me!

Many Thanks.

Error.png@

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Esteemed Contributor

Your operating system may not be supported.  ArcSDE technology has been 64-bit only since 10.0.

I'd recommend that you make sure your enterprise geodatabase host is executing on a 64-bit OS.

BTW: In the future, you should be sure to post "In a Place" rather than in your own blog space.

- V

View solution in original post

7 Replies
Highlighted
Regular Contributor

You don't need ArcSDE any more.  The software is able to connect directly to the SQL database.  Is the SQL database on the same server as ArcGIS Software?  If not, you will need to install the SQL Server Native Client on the machine that runs ArcGIS Software. 

Also, what license level of ArcGIS Software do you have? 

A quick tour of setting up a geodatabase in SQL Server: ArcGIS Help (10.2, 10.2.1, and 10.2.2)

Setting up a connection to SQL Server:  ArcGIS Help (10.2, 10.2.1, and 10.2.2)

Steven

Highlighted
New Contributor II

Hi Steven.

I problem is that when i create a Geodatabase that I built in SQL server i can't import any shapefile to it!

Reply
0 Kudos
Highlighted
Regular Contributor

I don't see any geodatabases in your image above.  Are you trying to import files into your database server directly because that will not work.

You need to create a geodatabase inside the database server (DELL_SQLEXPRESS.GDS) first.

Steven

Highlighted
Esri Esteemed Contributor

Your operating system may not be supported.  ArcSDE technology has been 64-bit only since 10.0.

I'd recommend that you make sure your enterprise geodatabase host is executing on a 64-bit OS.

BTW: In the future, you should be sure to post "In a Place" rather than in your own blog space.

- V

View solution in original post

Highlighted
New Contributor II

Hi dears!

I resolved my problem!

The reason was about my OS!

I changed my windows to 64 bit!

Thanks for everything!

Reply
0 Kudos
Highlighted
Regular Contributor

Glad to see you got it resolved. 

To help others in the future, you should mark Vince's Answer as Correct.

Highlighted
New Contributor II

Okay Steven!

But Before seeing Vince's answer I changed my OS! But no problem I do that!

Reply
0 Kudos