Can't Delete Feature Class in SDE

1504
2
Jump to solution
06-07-2017 09:00 AM
Highlighted
New Contributor

I am having trouble deleting a feature class in SDE.  I am the DBO for the database, and there are a couple of feature classes in there under a user name that I need to delete.  In trying to set permissions, I was given different levels to see what I could and could not do.  In doing this.  I created a couple of feature classes as tests, and now they won't delete.  They are titled ADS/username/layer name.   When i'm connected as the DBO, I try to delete them, and I get an error saying that they can't be deleted because I'm not the owner.  My thought is that being an owner should allow me to delete these without problem.  I have attached a screenshot of the errors that I'm getting.

Thanks in advance for any help on this.

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Esteemed Contributor

Check to see if the user you are connecting as has the 'sysadmin' Server Role applied to it.  If so, remove this and see that the user just has 'db_owner'.  You should then be able to delete feature classes owned by other users.  I'm not sure if this is by design or a bug.

View solution in original post

2 Replies
Highlighted
Esri Esteemed Contributor

Check to see if the user you are connecting as has the 'sysadmin' Server Role applied to it.  If so, remove this and see that the user just has 'db_owner'.  You should then be able to delete feature classes owned by other users.  I'm not sure if this is by design or a bug.

View solution in original post

Highlighted
Community Team

FYI... Moving the conversation to the Managing Data‌ group.  

So you're aware on how and where to post future questions, here's a few quick tips and reminders:

  • First, use the GeoNet search (top right corner by your profile icon) to search and see if your question has already by asked/answered previously.

Esri Community Strategist
Reply
0 Kudos