Can ArcMap 10.0 connect to a 10.2.1 Geodatabase

706
2
05-05-2017 03:25 PM
Highlighted
New Contributor III

I have a client who has some ArcGIS Desktop 10.0 installs and they were wondering if they can connect to a 10.2.1 Geodatabase. The 10.0 Client and geodatabase compatibility—ArcGIS Help | ArcGIS Desktop has an entry for 10.0 connecting to a 10.2 Geodatabase, but not 10.2.1 (either through Direct Connect or SDE service). Which is probably correct however I have seen errors in the documentation before and want to check that this is correct or not.

ArcGIS Desktop 10.0 geodatabase comparability matrix

My client is also thinking about moving to Oracle 12c, which I know is not supported, but I need to know that if they stayed at Oracle 11g then they could still connect.

Has anyone configured and successfully tested this configuration?

cheers.

Reply
0 Kudos
2 Replies
Highlighted
Occasional Contributor

From ArcMap 10.0, you can create a connection to geodatabase version 10.2.

Regarding the oracle database version supported with 10.0 Please have a look at the below link:

ArcGIS 10 System Requirements 

*Esri recommends that ArcGIS 10 clients connecting to 10.1 or later release geodatabases use 10 SP2, which contains several fixes to improve the user experience for connections.

ArcGIS Help (10.2, 10.2.1, and 10.2.2) 

Highlighted
MVP Regular Contributor

While the document doesn't specifically mention 10.2.1 and 10.2.2, there is a mention of it in that link suggesting that it should work:

While ArcGIS 10 clients can open, query, edit, and save data in 10.1, 10.2.x, and 10.3.x geodatabases, they cannot open datasets with 10.1, 10.2.x, or 10.3.x functionality and will encounter the following error message when trying to open one of these datasets:

The version of the Geodatabase client is incompatible with the dataset and cannot open it.