CAD Data Cannot Find/Display in ArcMAP

9196
13
09-22-2010 11:36 AM
JiaoniYang
New Contributor
Hello,

I have been working on adding CAD data into ArcGIS with no success, it just did not show anything.

In the dwg file layer property when examine using ArcCatalog,all the values from coordinates tab and details tab showed as zeros. I think this might be the problem, anyone knows how to solve it?

Everything seems working fine in AutoCAD. And I did save the dwg file as older version like AutoCAD 2000, or R14, but still failed display in ArcMAP.

Please help, thanks.

Joanie
0 Kudos
13 Replies
by Anonymous User
Not applicable
Original User: apt42

Hello,

I have been working on adding CAD data into ArcGIS with no success, it just did not show anything.

In the dwg file layer property when examine using ArcCatalog,all the values from coordinates tab and details tab showed as zeros. I think this might be the problem, anyone knows how to solve it?

Everything seems working fine in AutoCAD. And I did save the dwg file as older version like AutoCAD 2000, or R14, but still failed display in ArcMAP.

Please help, thanks.

Joanie


Hi Joanie,

I tested glass.dwg drawing with ArcGIS 10. Attached is the screenshot, I could not repro the problem. In your attached screenshots it says CFD_ex.dwg. Can you attach that?
0 Kudos
DelenoraGrey
New Contributor
I've been having the exact problem.  The AutoCad drawings I need to use show 0 features in all categories in ArcCatalog (identical to the posted thumbnails), and there is nothing visible in the preview, nor if I bring the drawing into ArcMap (ArcEditor level) - if I "zoom to layer" I get a blank screen.

However, I did see the lines and other features in the previous poster's Glass.dwg with no trouble, and have been able to see a few other drawings in our network drive.

Is there some sort of setting in AutoCad that allows/disallows a drawing to be visible if imported into a GIS?  I am still working in 9.3.1.  Thanks.
0 Kudos
by Anonymous User
Not applicable
Original User: apt42

I've been having the exact problem.  The AutoCad drawings I need to use show 0 features in all categories in ArcCatalog (identical to the posted thumbnails), and there is nothing visible in the preview, nor if I bring the drawing into ArcMap (ArcEditor level) - if I "zoom to layer" I get a blank screen.

However, I did see the lines and other features in the previous poster's Glass.dwg with no trouble, and have been able to see a few other drawings in our network drive.

Is there some sort of setting in AutoCad that allows/disallows a drawing to be visible if imported into a GIS?  I am still working in 9.3.1.  Thanks.


Hi Delenora,

Can you please attach the drawing?
0 Kudos
JenniferWoods
New Contributor
I am having a similar problem.  I have a CAD drawing from another company and I can see it fine in DWG TrueView 2010 program.  But when I look at the file in ArcReader their seems to be nothing there..in table view or geogrpahy view.  Any suggestions?
0 Kudos
by Anonymous User
Not applicable
Original User: apt42

I am having a similar problem.  I have a CAD drawing from another company and I can see it fine in DWG TrueView 2010 program.  But when I look at the file in ArcReader their seems to be nothing there..in table view or geogrpahy view.  Any suggestions?


Hi Jennifer,

Is it possible to attach the data? If not, can you contact Tech support?
0 Kudos
MichaelZecca
New Contributor
I have the same problem, as in I can view .dwg in autoCAD but not in ArcMAP. All fields are comming out as "0" and it is as if the file has no data in it. I tried to upload the .dwg file but no luck. Thank you.
0 Kudos
by Anonymous User
Not applicable
Original User: BGorevoy

I had the same problem - I could not view the DWG file in ArcMAP.

The problem turned out to be in the version of DWG.
I tried to view the version 2013 of DWG in ArcMAP 10. Apparently this DWG format was too new for ArcMAP.

When I saved DWG in the previous version (2010) I could see the DWG inside ArcMAP.
RichardPerkins
New Contributor II

This solved the 'no geometry' issue.  Saved the .dwg back to CAD 2000 version and .dwg appeared in ArcMap.  Had to use the Georeferencing tool to correct its location, but it did get into the file.  Thanks for the advice.

0 Kudos
MikeTanner4
New Contributor

This solved the issue for me as well. Saved the drawing to CAD 2010 and the linework appeared in ArcMap. Thanks for the great advice! 

0 Kudos