Attributes of Feature Classes in a Feature Dataset display in ArcGIS Pro but not visible in SQL Server Management Studio

262
1
12-15-2021 10:19 PM
Labels (1)
klandicho
New Contributor II

We have versioned feature classes in a feature dataset with archiving enabled which also participate in a topology. When we open the attribute tables in ArcGIS Pro, attributes are visible with no issues. Data can also be edited in ArcGIS Pro with no issue. However, when we open the tables in SQL Server Management Studio, attributes are not visible.

Before this issue was reported, attributes can be viewed with no issues in both ArcGIS Pro and SQL Server Management Studio.

For additional details, here are the software and OS versions used in the setup:

  • ArcGIS Pro 2.8
  • ArcGIS Enterprise 10.7.1
  • SQL Server 2016
  • Windows Server 2016

Has anyone encountered this issue in SQL Server? Does somebody have any idea of what can be causing this issue?

 

Thanks,

Karen

 

@mmarigmen 

0 Kudos
1 Reply
ChestonDobbins
New Contributor II

Hi Karen,

You mentioned:


Before this issue was reported, attributes can be viewed with no issues in both ArcGIS Pro and SQL Server Management Studio.


Can you provide some more details as to what changed since this issue has started?

If you are editing versioned data then those edits are stored in the a# & d# tables until the edits have been compressed, but there should be a versioned view that you can query from SQL Server Management Studio that will return results based on the version you set:

Read versioned data in SQL Server using versioned views—ArcMap | Documentation (arcgis.com)

Of course maybe I have misunderstood the issue, if so please clarify so I can try to help further.