ArcSDE 9.3.1 SP 2 on AIX 5.3 with Oracle 11gR2

664
5
08-29-2011 08:42 AM
ElizabethSelf
New Contributor
Hello,

We have been running ArcSDE 9.3.1 SP 1 on AIX 5.3 with Oracle 10.2.0.3 and upgraded the database last week to 11.2.0.1.  After the database upgrade, I installed the ArcSDE 9.3.1 and ArcSDE 9.3.1 SP2 per ESRI's instructions (installed the base but didn't do post install, installed SP2 then completed post install) but while trying to run sdesetup -o upgrade -d ORACLE11G -u sde I am getting the following errors:

ESRI ArcSDE Server Setup Utility Fri Aug 26 07:26:23 2011
----------------------------------------------------------------
Upgrade ArcSDE, GDB table schema:
   Are you sure? (Y/N): Y
Upgrading ArcSde schema.....
Successfully upgraded ArcSde schema.

Upgrading locators.....
Error:  0509-130 Symbol resolution failed for /u01/app/product/esri/sdeexe93/lib/libgsrvrora11g93_64.so because:
          0509-136   Symbol fc_softc (number 84) is not exported from
                    dependent module /u01/app/product/oracle/11.2.0/db_1/lib/libclntsh.so.
         0509-022 Cannot load module /u01/app/product/esri/sdeexe93/lib/libgsrvrora11g93_64.so.
         0509-026 System error: Cannot run a file that does not have a valid format.
         0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.
Error: Operation Failed (-1).
Error: Error upgrading locators .
SDE schema object install not completed.
Check SDEHOME\etc\sde_setup.log or
           SDEHOME\etc\sde_dc<rdbms>.log for more details..


And all that's in the log is:

[Fri Aug 26 07:26:25 2011] Instance initialized for ((sde)) . . .

[Fri Aug 26 07:26:25 2011] ArcSde is already at an acceptable release:
9.3.1
[Fri Aug 26 07:26:31 2011] Connection to sde failed(0)

According to ESRI documentation, Oracle 11gR2 is supported at ArcSDE 9.3.1 SP2 but when I entered a ticket with ESRI, I was told that it was hitting bug
[#NIM062679:  Running sdesetup -o install on Oracle 11G R2 64bit Standard Edition for ArcSDE fails with an error].  This bug though says it was found in ArcSDE 10 and is fixed in SP2.  I found an entry in the forums referencing this problem and the last message says:

"For technical reasons AIX ArcSDE 9.3.1 for Oracle 11g doesn't work with Oracle 11gR2. We have changed the way we link to the Oracle libraries at ArcSDE 10 on AIX. We will port this fix to ArcSDE 9.3.1 with Service Pack 2.

-- Dave"

http://forums.esri.com/thread.asp?c=158&f=2291&t=303773

Any help on this would be greatly appreciated because so far I've been told that our only fix is to go to ArcSDE 10 SP 2 so why list that ArcSDE 9.3.1 SP 2 is supported at my OS and database level?
0 Kudos
5 Replies
anthonysanchez
New Contributor III
Hello Elizabeth,
I have an idea assuming you are not using st_geometry.

install the oracle client on your pc.  Then install the sde binaries + patch you require.  Do the upgrade remotely.  Afterwards you can just use direct connect to your db server or if you really want a service, run the service remotely from another machine (not recommended).

Anthony
0 Kudos
DavidSwenson
New Contributor III
Elizabeth,

After the original problem with the install using Oracle 11gR2 Enterprise edition was discovered and fixed in ArcSDE 9.3.1 SP2. A second similar problem was discovered using Oracle 11gR2 Standard and Standard One editions. At this time we have only fixed this at ArcSDE 10 SP2. There are no current plans to fix this at a future patch of ArcSDE 9.3.1.

Are you able to move to ArcSDE 10 SP2?

-- Dave
0 Kudos
ElizabethSelf
New Contributor
Thank you gentlemen,

We are in the middle of a major change of several items so switching to direct connect or an upgrade of ArcSDE were not in the cards but it's looking like we'll have to one or the other.

May I ask, what are the locators for?  My application developer doesn't have any idea (I am the dba) what they are and he's able to start up the ArcCatalog and things seem to be working fine.  Kind of at a loss,

Appreciate your time,
elizabeth
0 Kudos
DavidSwenson
New Contributor III
Elizabeth,

LOCATORS is one of the ArcSDE schema tables. The upgrade process is failing while trying to upgrade the LOCATORS table. Being able to start ArcCatalog doesn't have any relationship with the upgrade of ArcSDE.

There is really nothing you can do to force the ArcSDE upgrade to succeed at ArcSDE 9.3.1 SP2 and Oracle 11gR2. If you have to use Oracle 11gR2 and can't upgrade to ArcSDE 10 SP2 please submit a support request to ESRI Technical Support. On AIX ArcSDE 9.3.1 SP2 we can only support Oracle 10gR2 and 11gR1.

--Dave
0 Kudos
ElizabethSelf
New Contributor
Thanks...we'll figure out one way or the other to go then.  Appreciate everyone's help.

--Elizabeth
0 Kudos