ArcSDE 10.1 sp1 upgrade geodatabase error: DB_arcsde_setup: Unable to connect

3647
4
Jump to solution
04-08-2014 01:52 AM
Highlighted
New Contributor III
Hi All,

While trying to upgrade my ArcSDe geodatabase from 10.1 to 10.1 sp1 with Oracle getting below error as recorded in the SDE_Setup log file.

[Tue Apr 08 14:33:21 2014]
ST_Geometry Schema Owner: (SDE) Type Release: 1007
[Tue Apr 08 14:33:21 2014] Instance initialized for ((sde)) . . .

[Tue Apr 08 14:33:21 2014] Error: Underlying DBMS error (-51).
[Tue Apr 08 14:33:21 2014] Error: DB_arcsde_setup: Unable to connect
[Tue Apr 08 14:33:21 2014] ORA-00933: SQL command not properly ended

[Tue Apr 08 14:33:21 2014] ERROR installing/upgrading ArcSDE, Error = -51

User privileges for geodatabases in Oracle are verified from the below webhelp link:
http://resources.arcgis.com/en/help/main/10.1/index.html#//002n0000002v000000

Also I connect to the geodatabase as ArcSDE admin user (SDE), run the following query and attached is the exported file which looks good:
select object_name, object_type, created, last_ddl_time, status from user_objects where object_type in ('OPERATOR','PACKAGE','PACKAGE BODY','INDEXTYPE','FUNCTION','TYPE','TYPE BODY');

referred the below forum link:
http://forums.arcgis.com/threads/18033-ArcGIS-10-Upgrada-Geodatabase-Error

Attached is the exported file for your reference.

Any suggestion is appreciated.

Regards,
Amit
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Regular Contributor III
You could be encountering a known NIM:
http://support.esri.com/en/bugs/nimbus/TklNMDg2NDEw

[ NIM086410 - Upgrading an Enterprise geodatabase using a database connection established with the traditional syntax for direct connections fails with error 'ORA-00933: SQL command not properly ended']


Try creating a new connection to the Oracle geodatabase using only the TNSNAME(oracle netservice_name) and then try the upgrade.

View solution in original post

Reply
0 Kudos
4 Replies
Highlighted
Esri Esteemed Contributor
The version of Oracle (exact version, in A.B.C.D.E notation) is far more important
than the list of objects owned by the SDE user.

- V
Reply
0 Kudos
Highlighted
Regular Contributor III
You could be encountering a known NIM:
http://support.esri.com/en/bugs/nimbus/TklNMDg2NDEw

[ NIM086410 - Upgrading an Enterprise geodatabase using a database connection established with the traditional syntax for direct connections fails with error 'ORA-00933: SQL command not properly ended']


Try creating a new connection to the Oracle geodatabase using only the TNSNAME(oracle netservice_name) and then try the upgrade.

View solution in original post

Reply
0 Kudos
Highlighted
New Contributor II

You're a star sir. Solution fixes 10.2.2 upgrade issue I am having as well.

thanks

Dan

Reply
0 Kudos
Highlighted
New Contributor III
Thanks Ashru,

That did the trick 😮

Regards,
Amit
Reply
0 Kudos