ArcMap crash when open MXD with layer from Application connect to SDE

1105
7
02-07-2017 01:17 AM
Highlighted
Regular Contributor II

Hello all.

We use ArcGIS 10.3.1 with Oracle11g on Linux.

We can open a clean ArcMap, open an application connect to the database, drag any layer and save the MXD.

The layer is visible and looks fine.

When we close ArcMap and try to reopen the MXD (by double click or open project from ArcMap) ArcMap just crash.

The same process works when we use direct connect.

The first process worked fine until 3 days ago but the Linux and Oracle people say they change nothing (surprise…).

We know we should use direct connect but we have many old MXD's that uses application connect that we cannot even fix them.

The only thing is the logs are status 8 (Lost Client).

We know we need to start SDE with debug mode and check oracle errors but this is production server so it will take some time.

Anybody has any idea what can cause such a problem?

 

Thanks

Reply
0 Kudos
7 Replies
Highlighted
MVP Regular Contributor

If migrating to Direct Connections is an option, you can create new Direct Connections to the Enterprise GDBs and then resource the MXDs to those new connections (without having to open the existing MXD). This should get you going for the time being.

arcmap - How do I change the data source for all layers in an MXD? - Geographic Information Systems ... 

I am not completely sure, but I remember an issue like this which was logged as a Defect (may have been fixed by now), however I cannot find that right now. Maybe someone else may point to that.

Reply
0 Kudos
Highlighted
MVP Regular Contributor

Also is the issue while trying to open with ARcGIS 10.3.1 only?

Do the MXDs open fine if you use Desktop 10.2.2 or 10.4.x 

Reply
0 Kudos
Highlighted
Regular Contributor II

Hi Asrujit

Thanks for you input.

We tried to fix using ArcCatalog - it crash ArcCatalog.

The MXD was created in 10.3.1 and the geodatabase is 10.1

We tried to open the MXD in 10.4 with the same results.

Any other ideas?

Reply
0 Kudos
Highlighted
MVP Regular Contributor

Do the MXDs have any Raster Data in them?

Reply
0 Kudos
Highlighted
Regular Contributor II

No rasters.

We tries MXDoctor. It show no errors. We tried to hit Fix anyway to create a new MXD. The new MXD crash too.

Reply
0 Kudos
Highlighted
Esteemed Contributor

Do you have any plans on upgrading your geodatabase since it is 2 major releases behind your desktop software?

Does the same crashing phenomenon occur on different computers?

Does the same crashing phenomenon occur for a different user on the same machine?

Reply
0 Kudos
Highlighted
Regular Contributor II

It append for all computers and users.

We are now trying to find a non production database that will show the same problem, then we can run some tests, debug, oracle trace etc.

It is not simple to do any testing on production.

Upgrade the database is planed but not soon...

Thanks

Reply
0 Kudos