Address locator (10.6 release) fails to locate intersections of numbered streets

1687
18
03-25-2019 02:49 PM
DevonHedemark
New Contributor

We use a US Dual Range Address locator (10.6 style release) and it does not return results for intersections with the numbered street typed first?  We had the same behavior with a 10.5 style release.

If I search "west st and 8th st" it works fine.  If I search "8th st and west st" it does not return any results.

This behavior is the same using the Find tool or the geocoding toolbar in ArcMap.  Is this a known bug?

Regards, Devon

0 Kudos
18 Replies
JoeBorgione
MVP Esteemed Contributor

We had the same behavior with a 10.5 style release.

Do you mean that  8Th ST & West ST did not work in 10.5?

That should just about do it....
0 Kudos
DevonHedemark
New Contributor

Correct, 8Th ST & West ST did not work in 10.5

0 Kudos
JoeBorgione
MVP Esteemed Contributor

Ours 10.6 US Dual Range seems to work just fine, at least with the find tool:

8th ave & D st works too.  We have prefix directions so E 8th ave & N D st works as well.

Not sure what could be causing your problem....

That should just about do it....
DevonHedemark1
New Contributor III

Interesting.  Our locator is part of a public safety system and the locator style name does have a reference to their system. But, I am testing outside of that application.  

0 Kudos
JoeBorgione
MVP Esteemed Contributor

May I ask what CAD you are using?  I've worked quite a bit with Spillman...

That should just about do it....
0 Kudos
DevonHedemark1
New Contributor III

Yes, it is Spillman.

0 Kudos
JoeBorgione
MVP Esteemed Contributor

So you are publishing a gecoding service which Spillman consumes. I used 10.3.1 locators when I was working in 9-1-1, and never had a problem with those either.  I was using a composite, but that shouldn't matter.  It may be as simple as a setting in your locator set up or at worst a data problem, but without seeing either, I don't want to venture a guess.  It may be time to get ESRI Tech Support involved.  Seems like Spillman had a couple hot-hands on staff.  They may be able to give you some help as well.

Shana Britt‌ might be able to give you a pointer too....

That should just about do it....
0 Kudos
DevonHedemark1
New Contributor III

You are correct. We use a composite as well.  I think I will submit an Esri ticket.  

0 Kudos
ShanaBritt
Esri Regular Contributor

Devon:

Did you get your issue resolved through Tech Support?

If you have access to ArcGIS Pro 2.3 I would suggest using the Create Locator tool using the StreetAddress role and adding it to a composite locator and use it in the Spillman application. I'm not sure if the locator created with the Create Locator tool will work with their application or not, but there is no change in the composite locator that you create with the Create Composite Address Locator tool in either ArcMap or ArcGIS Pro.

0 Kudos