Add Global IDs error

210
2
07-29-2013 05:06 AM
Highlighted
New Contributor II
I am getting an error when I try to add Global IDs to a feature dataset within an SDE: "Invalid database name"
I've attached a screen shot of the error. I am using ArcGIS 10.0.


Thanks,
S
Reply
0 Kudos
2 Replies
Highlighted
Occasional Contributor III
I think you need to add Global IDs not to the Feature Dataset itself, but rather to the individual feature classes within the feature dataset.
Reply
0 Kudos
Highlighted
MVP Regular Contributor
Please confirm that you are using SQL Server and, if so, the version of the RDBMS software. 

Is �??basemap�?� the name of your DATABASE within your SQL Server instance?
Is �??SUFFOLKGIS" the name of the SCHEMA within your database?
Is �??COGO_Linework�?� a valid feature class within ArcSDE? 

Which user account are you logged in with while attempting to add Global IDs?  Check the permissions of that user account within the basemap database itself.  Which roles are assigned to it?  Do you see any roles checked that might point to a denial of privileges, such as db_denydatareader? 

It is possible that the user account being used in your connection string doesn�??t have the right permissions to perform this type of operation.  Can that account at least see the features within the feature class during a Preview in ArcCatalog?  Try assigning the db_owner role to that user account and then try to add Global IDs again.  Otherwise, try connecting with the SDE or DBO account to do this and see if that works.
Reply
0 Kudos