Problems with the Storytelling Map Tour Template (hosted)

2461
13
Jump to solution
11-12-2013 07:27 AM
GwenFord
New Contributor
I trying to use the Storytelling Map Tour Template, but the images only come up in the thumbnail strip but not the large photo with caption. I have the same urls being referenced for both the thumbnails and the large photo.

http://www.arcgis.com/apps/MapTour/index.html?appid=3d075ceb72d64c1483bf5beade1fdd61&webmap=f3ebddf6...

Also, my map keeps losing the edits that I've saved to it like changing the symbols and configuring the pop-ups. I've updated and saved the map 3 times now and it keeps reverting back to default settings.
0 Kudos
1 Solution

Accepted Solutions
AnthonyGiles
Frequent Contributor II
Mapdoggis,

As you can see from the attached image, some of the URLs look corrupted,

Regards

Anthony

View solution in original post

0 Kudos
13 Replies
AnthonyGiles
Frequent Contributor II
Hi,

I have just followed your link using my iPad and the large photos seem to be working, although only about 50% of them, not sure if this is caused by incorrect URLs, it might be worth checking all your links are correct and accessible,

Regards

Anthony
0 Kudos
GwenFord
New Contributor
If the thumbnail urls and the large photo urls are the same, how is it that one shows and the other doesn't?
0 Kudos
AnthonyGiles
Frequent Contributor II
The only thing I could think why this may happen is that the thumbnails are created from the URL at the time you create the tour, if the URL changes after the tour has been created the thumbnail may still exist but the link to the full image does not.

Have you checked your links are still valid?
0 Kudos
GwenFord
New Contributor
All links are still valid.
http://71.6.218.49/transit/images/Cameras/College_Dr_at_Kivett_Dr.jpg
http://71.6.218.49/transit/images/Cameras/Kivett_Dr_US311.jpg
http://71.6.218.49/transit/images/Cameras/Westchester_Dr_at_Lexington_Ave.jpg
http://71.6.218.49/transit/images/Cameras/Market_Center_Dr_at_English_Rd.jpg
http://71.6.218.49/transit/images/Cameras/Market_Center_Dr_at_Green_Dr.jpg
http://71.6.218.49/transit/images/Cameras/Main_St_at_Bus_I85.jpg
http://71.6.218.49/transit/images/Cameras/Green_Dr_US311.jpg
http://71.6.218.49/transit/images/Cameras/Main_St_at_Fairfield_Rd.jpg
http://71.6.218.49/transit/images/Cameras/US311_at_I85_Archdale.jpg
http://71.6.218.49/transit/images/Cameras/US2970_US311.jpg
http://71.6.218.49/transit/images/Cameras/Jackson_Lake_R_US311.jpg
http://71.6.218.49/transit/images/Cameras/I85_NB_US311.jpg
http://71.6.218.49/transit/images/Cameras/I85_SB_US311.jpg
http://71.6.218.49/transit/images/Cameras/Commerce_Ave_Hamilton_St.jpg
http://71.6.218.49/transit/images/Cameras/Commerce_Ave_Wrenn_St.jpg
http://71.6.218.49/transit/images/Cameras/Green_St_at_Wrenn_St.jpg
http://71.6.218.49/transit/images/Cameras/Commerce_Ave_at_Elm_St.jpg
http://71.6.218.49/transit/images/Cameras/Main_St_High_Ave.jpg
http://71.6.218.49/transit/images/Cameras/Main_St_Lexington_Ave.jpg
http://71.6.218.49/transit/images/Cameras/Main_St_Eastchester_Dr.jpg
http://71.6.218.49/transit/images/Cameras/Hartley_Dr_Main_St.jpg
http://71.6.218.49/transit/images/Cameras/US311_US311_Bypass.jpg
http://71.6.218.49/transit/images/Cameras/Johnson_St_US311.jpg
http://71.6.218.49/transit/images/Cameras/Eastchester_Dr_Johnson_St.jpg
http://71.6.218.49/transit/images/Cameras/Eastchester_Dr_Gallimore_Dairy_Road.jpg
http://71.6.218.49/transit/images/Cameras/Hartley_Dr_West_Mall.jpg
http://71.6.218.49/transit/images/Cameras/Guilford_College_Rd_Wendover_Ave.jpg
http://71.6.218.49/transit/images/Cameras/Eastchester_Dr_North_Mall.jpg
http://71.6.218.49/transit/images/Cameras/Eastchester_Dr_US311_Bypass.jpg
http://71.6.218.49/transit/images/Cameras/Eastchester_Dr_Wendover_Ave.jpg
http://71.6.218.49/transit/images/Cameras/Eastchester_Dr_Piedmont_Pkwy.jpg
http://71.6.218.49/transit/images/Cameras/Greensboro_Rd_Guilford_College_Jamestown.jpg
http://71.6.218.49/transit/images/Cameras/Greensboro_Rd_US311.jpg
0 Kudos
AnthonyGiles
Frequent Contributor II
I'm at a loss then, there should be no reason, maybe some tech help from esri can shed some light?
0 Kudos
GregoryL_Azou
Regular Contributor II
Hi,

Sorry about that, the URL of your pictures are corrupted. Let me know if you can reproduce the corruption.

From now you can clearly see the affected points with the Table in ArcGIS.com map viewer http://www.arcgis.com/home/webmap/viewer.html?webmap=f3ebddf60c3249d285f26e4b80b5bb0a

You should be able to URLs with the builder, otherwise let me know and as a workaround you can fix them by editimg the layer in ArcGIS.com map viewer.

Regards
0 Kudos
AnthonyGiles
Frequent Contributor II
Mapdoggis,

As you can see from the attached image, some of the URLs look corrupted,

Regards

Anthony

View solution in original post

0 Kudos
LizGoldman1
New Contributor III
It sounds like your links are corrupted, but just wanted to add that I've had luck creating a large and thumbnail version of my photos with the map tour. As taken from the map tour readme doc, the large photo should ideally be 1000x750 pixels, and the thumbnail should be 140x93. I just cropped my photos by using a 10x7.5/3x2 ratio and resized in photoshop. I think there is quite a bit of wiggle room for sizes, but this ensures your photos will look good on a variety of monitor sizes.
Good luck!
0 Kudos
GwenFord
New Contributor
So for whatever reason, my Locations.csv gets corrupted online and I have to reload the same table every so often. This may explain why my camera symbols will randomly change back to the default orange dot. At least now, I know how to look at the table and see if my urls are corrupted. Thanks everyone.
0 Kudos