Pop-up in Web Map shows "image can't be displayed"-symbol in Cascade

435
3
Jump to solution
04-09-2020 10:12 AM
JosefineKlaus
New Contributor

Hey,

i've created a Cascade Story Map including web maps. If i use the pop-up-tool to show further information there is not only the desired text but also the symbol for images which can't be displayed. Though I didn't include any pictures.

Some advice/similar problems/recommendations?

Thanks a lot.

- Josie

0 Kudos
1 Solution

Accepted Solutions
OwenGeo
Esri Frequent Contributor

Often this is a security issue caused by the pop-up image link using an HTTP protocol instead of HTTPS. The new ArcGIS StoryMaps is only available using HTTPS, and ArcGIS Online is moving toward this as well. If your organization still does not require HTTPS, then you may be able to load a classic story map over HTTP and see the pop-up image in the same web map.

If you edit the URLs of the images in the pop-up to use HTTPS links I believe they should appear.

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

3 Replies
KateCarlson
Occasional Contributor

Hi Josie-  FYI, your foo.png is showing a sample from the new StoryMap Builder, not the Class template builder.  I have seen this too, no image displays in the pop-up when presented in the new StoryMaps, thought my attributes do display.  

I do not know the answer as to why web map pop-ups in the new builder do not show the pop-up media, perhaps that functionality is not set up and they are waiting for the full release of the new Map Viewer?  Hope you get more clarity for this post! 

Thanks-

Kate

0 Kudos
OwenGeo
Esri Frequent Contributor

Often this is a security issue caused by the pop-up image link using an HTTP protocol instead of HTTPS. The new ArcGIS StoryMaps is only available using HTTPS, and ArcGIS Online is moving toward this as well. If your organization still does not require HTTPS, then you may be able to load a classic story map over HTTP and see the pop-up image in the same web map.

If you edit the URLs of the images in the pop-up to use HTTPS links I believe they should appear.

Owen Evans
Lead Product Engineer | StoryMaps
KateCarlson
Occasional Contributor

Thank you, Owen.  That was it, I added 's' to 'http' and now they work!  I completely forgot about https requirements for the new StoryMaps.  

Kate