I need your help ....why can't I share post a story map on Facebook ....where all the sources and files are made PUBLIC and everything works just fine ?

511
4
Jump to solution
01-25-2018 06:26 PM
DanielBetts2
New Contributor II
0 Kudos
1 Solution

Accepted Solutions
RupertEssinger
Frequent Contributor II

Hi Daniel, I saw on another Geonet thread that you are posting this into Facebook and are getting an unexpected message back from Facebook when you do that. I can also reproduce that. Sorry about the issue

I'm not sure why that message is being returned in the default Facebook 'social card', and I've made a note of it with our team to see if anyone can explain it, or perhaps a Geonetter can explain it. I've not been able to reproduce that message with other story maps and I tried a bunch.

I think the story map is working fine and is shared publicly irrespective of what that message in the Facebook social card says. You can actually just close that errant social card by clicking the x control on it

and go head and do your Facebook post, adding any additional text or graphics that you want to include in the post. I just tried that in FB and it worked OK for me.

Rupert

View solution in original post

4 Replies
OwenGeo
Esri Frequent Contributor

Hi Daniel -- I can open and see your story map just fine. Did you fix the issue after posting your question or is there something else unexpected you see?

Owen Evans
Lead Product Engineer | StoryMaps
RupertEssinger
Frequent Contributor II

Hi Daniel, I saw on another Geonet thread that you are posting this into Facebook and are getting an unexpected message back from Facebook when you do that. I can also reproduce that. Sorry about the issue

I'm not sure why that message is being returned in the default Facebook 'social card', and I've made a note of it with our team to see if anyone can explain it, or perhaps a Geonetter can explain it. I've not been able to reproduce that message with other story maps and I tried a bunch.

I think the story map is working fine and is shared publicly irrespective of what that message in the Facebook social card says. You can actually just close that errant social card by clicking the x control on it

and go head and do your Facebook post, adding any additional text or graphics that you want to include in the post. I just tried that in FB and it worked OK for me.

Rupert

View solution in original post

DanielBetts2
New Contributor II

Got it fixed ....just completely rebuilt a new one ....works like a charm

There seems to be quite a bit of variance in which CREATE button you use

....best results were to build from the Web Map app itself and not from the

Create Button on AGOL Content page

Thank you very much

0 Kudos
RupertEssinger
Frequent Contributor II

I just saw another example of this same issue with the Facebook preview when posting a Story Map Crowdsource. The story didn't have a thumbnail, and adding the thumbnail (via My Stories) seemed to fix the issue. I'm not sure if that explains the issue, but will report back if we can track it down.

Rupert