Problem with exporting Pashto font in ArcGIS 10.3

260
1
Jump to solution
11-02-2019 01:22 AM
Highlighted
New Contributor

Hi, 

I am trying to export a map in Pashto language. When I export the map as Image it shows the font correctly but it's not working in case of PDF. I have also tried the option of embedding font while exporting the document.

I am using Adobe Arabic font, please share if there is any solution to this problem. 

Below is the screenshot for further explanation, showing the comparison of before and after exporting the document. 

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Regular Contributor

We've made several fixes that might improve the export results in later versions of ArcGIS - though in general our handling of contextual shaping and kashidas in ArcGIS Pro is much better than in ArcMap, as we are not limited by Microsoft GDI.

I'd recommend:

1.  Try updating to a more current release of ArcMap (10.6.1 or layer should have the fixes I'm thinking of, current release is 10.7.1)

2.  Try importing the MXD into ArcGIS Pro and exporting it from there.  You can install ArcGIS Pro alongside any version of ArcMap, and if your Desktop license is current then you also have a license of Pro.

Beyond this, I'd recommend sending this in to Esri tech support so a support tech can more interactively troubleshoot your problem.

Regards,

Jeremy W.

View solution in original post

1 Reply
Highlighted
Esri Regular Contributor

We've made several fixes that might improve the export results in later versions of ArcGIS - though in general our handling of contextual shaping and kashidas in ArcGIS Pro is much better than in ArcMap, as we are not limited by Microsoft GDI.

I'd recommend:

1.  Try updating to a more current release of ArcMap (10.6.1 or layer should have the fixes I'm thinking of, current release is 10.7.1)

2.  Try importing the MXD into ArcGIS Pro and exporting it from there.  You can install ArcGIS Pro alongside any version of ArcMap, and if your Desktop license is current then you also have a license of Pro.

Beyond this, I'd recommend sending this in to Esri tech support so a support tech can more interactively troubleshoot your problem.

Regards,

Jeremy W.

View solution in original post