Which Visual Studio edition for ArcGIS 10 development?

2856
15
07-15-2010 06:39 AM
New Contributor
At release both VS 2008 and VS 2010 are supported platforms. 

We're starting a new project and trying to decide if this is the time to jump to VS 2010.  Can anyone share experience with the two platforms? 

Both do what we need to do, but I'm wondering if I'll kick myself 3 years from now for beginning new work with an older set of development tools.  (I'm also wondering if I'll kick myself sooner for using development tools that don't yet have their first service pack...)

Charlie Richman
Reply
0 Kudos
15 Replies
New Contributor
VS 2010 is not supported - you are "stuck" with VS 2008
Reply
0 Kudos
by
New Contributor III
VS 2010 is not supported - you are "stuck" with VS 2008


Where is the reference for this? I think there are many statements (do a search for "Visual Studio 2010") from ESRI that Visual Studio 2010 works with ArcGIS 10...
Reply
0 Kudos
New Contributor
ArcGIS 10 Pre-release = VS 2008 only.
ArcGIS 10 at official release = VS 2008 or VS 2010.

(that's why I'm asking)

Charlie Richman
DC Office of Planning
Reply
0 Kudos
New Contributor
According to the ArcObjects 10 (released version) help file:

Supported versions of Microsoft Visual Studio
In this Help system, you will often see references to Visual Studio, both as part of the requirements and part of the topics. Such references refer to any supported version of Microsoft Visual Studio, unless otherwise indicated. At ArcGIS 10, Microsoft Visual Studio 2008 is supported, including express editions.


Doug.
Reply
0 Kudos
New Contributor
Perhaps I was mislead by earlier ESRI assertions that it would be supported at release?
Reply
0 Kudos
Esri Regular Contributor
Visual Studio 2010 is supported.  Check out -  http://resources.arcgis.com./content/arcgissdks/10.0/system-requirements#DeveloperSolutions

Thanks,

Chris
Reply
0 Kudos
New Contributor
Yeah, it looks as if VS2010 is supported but you have to target the 3.5 framework:

http://resources.arcgis.com/content/arcgissdks/10.0/system-requirements

Doug.
Reply
0 Kudos
New Contributor
Ok, now that we've established that VS 2010 is supported (thanks folks) are there enough compelling reasons to upgrade now for ArcGIS development?
Reply
0 Kudos
New Contributor
Seeing as how you still can't target the 4.0 framework, the only reason I would consider upgrading is for the VS2010 IDE enhancements.

Doug.
Reply
0 Kudos