Visual Studio Debuging Problem - Cannot find pdb for ArcMap.exe

4720
1
Jump to solution
01-23-2013 10:32 AM
New Contributor III
Hi guys.  Trying to create a new extension for ArcMap and am having trouble getting debugging to work.  I can get the extension - a toolbar with buttons and code of course - to loadup in arc properly and I can click the button and fire the code.  Everything seems to work but the thing I cannot get to work are breakpoints in VS.

I keep getting "Debugging information for 'ArcMap.exe' cannot be found or does not match.  Cannot find or open the PDB file.  Here are the steps I went through:

1.  Under Tools>Options of VS, I added an entry for 'http://downloads2.esri.com/Support/symbols/' in the Debugging>Symbols section and I gave it an explict path to cache to.  This seems to work as I get a whole bunch PDB files downloaded related to ESRI DLLs (nothing about the actual arcmap.exe file).

2. In the Project Properties>Debug screen I set the radio to "Start external program" and point it at the arcmap.exe file.

3.  Without "Enable unmanaged code debugging" at the bottom check everything loads without error and debugging does not work.  With that option checked, I get the error about not finding the ArcMap.exe pdb file but debugging still does not work.

Any insight?

Thanks
Ernie
Reply
0 Kudos
1 Solution

Accepted Solutions
New Contributor III
Nevermind, I figured it out.  Had to remove the version reference in the arcmap.config file:

http://gis.stackexchange.com/questions/13606/why-cant-the-breakpoint-be-hit-when-debugging-an-arcgis...

Ernie

View solution in original post

Reply
0 Kudos
1 Reply
New Contributor III
Nevermind, I figured it out.  Had to remove the version reference in the arcmap.config file:

http://gis.stackexchange.com/questions/13606/why-cant-the-breakpoint-be-hit-when-debugging-an-arcgis...

Ernie

View solution in original post

Reply
0 Kudos