Visual Basic retired...!?

455
3
Jump to solution
11-28-2013 04:42 AM
Highlighted
New Contributor
Dear all,
I am currently developping for ArcGIS 9.2 using ArcObjects and Visual Studio 2005 (still...) . I use VB.NET as programming language. Now I want to switch to ArcGIS 10.0 / Visual Studio 2008.
My friends keep telling me: "Visual Basic will not be supported any more!" ... and first these rumours shocked me quite a bit.
Then a Google research showed: VB6 is not supported any more ,and VBA will not be supported in ArcGIS 11 or so, but VB.NET will still be supported for ArcGIS 10.0, 10.1, and the upcoming versions.... right??? Just to make sure!!! 🙂 Otherwise I will switch to C#.
Thanks for your answers!!
Regards, Johannes
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Occasional Contributor III
http://downloads2.esri.com/support/TechArticles/W26496_W25918_DEPRECATION_PLAN_FOR_ARCGIS_101_and_10...

According to the 10.2 deprecation plan above, 10.2 is the last major release to include VBA compatibility. As far as I know, VB.NET and Visual Studio will be supported and the preferred language (over VBA).

Someone may be able to provide more info, but the only limitations I'm aware of is the actual version of Visual Studio that's supported. 2008 for ArcGIS 10.0, 2010 for ArcGIS 10.1 (and 10.2 I believe).

I'm currently using VS2010, VB.NET...I believe ESRI will support this combo for the foreseeable future.

Hope this helps!

Edit: didn't mean to ignore Java/C# etc... those are also fully supported languages as far as I'm aware, but I'm only familiar with/keep tabs on VB.NET support.

View solution in original post

0 Kudos
3 Replies
Highlighted
Occasional Contributor III
http://downloads2.esri.com/support/TechArticles/W26496_W25918_DEPRECATION_PLAN_FOR_ARCGIS_101_and_10...

According to the 10.2 deprecation plan above, 10.2 is the last major release to include VBA compatibility. As far as I know, VB.NET and Visual Studio will be supported and the preferred language (over VBA).

Someone may be able to provide more info, but the only limitations I'm aware of is the actual version of Visual Studio that's supported. 2008 for ArcGIS 10.0, 2010 for ArcGIS 10.1 (and 10.2 I believe).

I'm currently using VS2010, VB.NET...I believe ESRI will support this combo for the foreseeable future.

Hope this helps!

Edit: didn't mean to ignore Java/C# etc... those are also fully supported languages as far as I'm aware, but I'm only familiar with/keep tabs on VB.NET support.

View solution in original post

0 Kudos
Highlighted
New Contributor
Dear GeoffAppleby,
thank you for your answer. That helps perfectly and confirms what I was expecting.
Best, Johannes
0 Kudos
Highlighted
Occasional Contributor III
No problem, glad I could help!

Was hoping some veterans might be able to confirm, but I think if they see something incorrect they will notify us.

Cheers,
0 Kudos