Problem migrating ArcObjects .NET 10.3.1 to 10.4 ?

7141
9
02-26-2016 05:32 AM
Highlighted
Occasional Contributor

Hi,

I need to migrate a desktop app from 10.3.1 to 10.4.

I have installed ArcGIS 10.4 pre-release and am confronted with these problems :

The type or namespace name 'ADF' does not exist in the namespace 'ESRI.ArcGIS'

The name 'RuntimeManager' does not exist in the current context

Have they been removed ?

Also I understood that MSVIsual Studio 2010 is no longer supported.

Tags (2)
Reply
0 Kudos
9 Replies
Highlighted
MVP Frequent Contributor

Have you set target 4.5 net in your project?

system requirments: vs 2013 - vs 2015 https://desktop.arcgis.com/en/system-requirements/latest/arcobjects-sdk-system-requirements.htm

Reply
0 Kudos
Highlighted
Esteemed Contributor

Before trying to migrate this desktop app to 10.4, what version of desktop did you migrate from to get to 10.3.1?

Have you tried to just install your 10.3.1 compiled app onto the 10.3.1 machine to see if it would work?

Reply
0 Kudos
Highlighted
Occasional Contributor

Before trying to migrate to 10.4 my app worked on 10.1, 10.2 and 10.3.

I was using MS Visual Studio 2010 with .NET 4

Reply
0 Kudos
Highlighted
Occasional Contributor

I did but then I have a message telling me that ESRI.ArcGIS.ADF was built in a x86 architecture.

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

Have you removed StOLE ?

Set in properties Project Platform x86

for adf select

ArcObjects SDK 10.4 system requirements—System Requirements | ArcGIS for Desktop

Reply
0 Kudos
Highlighted
Occasional Contributor

When I tried to build, I got hundreds of errors related to the numerous type changes between 10.3 and 10.4 [1]. Seems similar to your ADF missing type error.  I didn't see a utility to update the types in Visual Studio 2013. Is there an automated way to do this?

[1] https://desktop.arcgis.com/en/arcobjects/latest/net/webframe.htm#d018a65d-574a-4964-a72c-77f16d1c431...

Reply
0 Kudos
Highlighted
Esteemed Contributor

Tim:

Did you try to see if the existing application would install and run on the 10.4 desktop without recompiling the code?

Reply
0 Kudos
Highlighted
Occasional Contributor

In my testing, running the add-in compiled for 10.3 works in ArcMap 10.4. However, some of my customers require the add-in to be compiled against the version of ArcGIS that they are actually using.

Reply
0 Kudos
Highlighted
Occasional Contributor

I resolved my problem by setting "Embed Interop Types" to False for all ESRI.ArcGIS references. You can select all of those references in the solution explorer and change that property all at once. However, I didn't see an ADF error in my list though I do have a reference to ESRI.ArcGIS.ADF, so I suspect this will not solve the original post.