Java Development, Eclipse plug-in

2035
4
01-29-2012 10:49 PM
paulromanchenko
New Contributor
Hello. Just installed ArcGIS Desktop trial to see how I can develop apps with Java for ArcGIS.

Eclipse plugin seems to be outdated, as it requires Eclipse Visual Editor which is unavaliable today (not for current eclipse, not for 3.3).

Is Java still supported? Is there updated eclipse plugin to download?

Thanks.
0 Kudos
4 Replies
LeoDonahue
Regular Contributor
Eclipse Visual Editor was only needed to do visual drag/drop of ArcEngine components, and you are correct in that the Eclipse VI project is retired.  However, you can still download that project and use it with Eclipse 3.6.(something - I forget).

Is Java still supported?
Yes. 
Is there updated eclipse plugin to download?
Use the one from the ArcGIS installation directory.

Although not supported by ESRI, Eclipse Java Indigo 3.7.1 will work fine with the plugin from the ArcGIS installation directory, you just don't get the visual drag/dop stuff for ArcEngine map controls, toc controls, etc.

All of the configuration is clearly in the ArcObjects Project code, if you wanted to change it.
0 Kudos
LeoDonahue
Regular Contributor
I was able to get Visual Editor 1.5.0.R20101202-1328 installed with Eclipse Java Helios 3.6.2

http://wiki.eclipse.org/VE/Installing
0 Kudos
paulromanchenko
New Contributor
Eclipse Visual Editor was only needed to do visual drag/drop of ArcEngine components, and you are correct in that the Eclipse VI project is retired.  However, you can still download that project and use it with Eclipse 3.6.(something - I forget).

Yes. 
Use the one from the ArcGIS installation directory.

Although not supported by ESRI, Eclipse Java Indigo 3.7.1 will work fine with the plugin from the ArcGIS installation directory, you just don't get the visual drag/dop stuff for ArcEngine map controls, toc controls, etc.

All of the configuration is clearly in the ArcObjects Project code, if you wanted to change it.


Well, I have ArcGIS for Java installed to E:\programs\arcgis-java and I use E:\programs\arcgis-java\DeveloperKit10.0\java\tools\eclipse_plugin\arcgis_update_site\arcobjects\  as Update Site for Eclipse.

There is error I get when install plugin:

ESRI ArcObjects Palette (10.0.0.2414) requires plug-in "org.eclipse.ve.java.core".

I use latest ArcGIS trial.
0 Kudos
LeoDonahue
Regular Contributor
If I recall correctly, when you install the eclipse plugin, there are two check boxes.  Don't check the box that mentions something about the "pallette", otherwise, you'll need to find, download and install the VE plugin for eclipse.
0 Kudos