ArcObjects SDK for .NET 10.2 add-in deployed in ArcDesktop 10.1?

3292
1
Jump to solution
05-29-2015 09:05 AM
Highlighted
New Contributor III

Should it be possible to build an add-in using ArcObjects SDK for .NET 10.2 and deploy the add-in in ArcMap 10.1? I have just tried that and ArcMap 10.1 crashed.

To give you some context, my dev machine runs ArcDesktop 10.2.2 but I'm developing extensions for an organisation that has ArcDestop 10.1 only. What is the best practice in such circumstances?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Frequent Contributor

Short answer is no. You need a developer machine that has the same version if your client is using an older version of Arcmap. I have found addins are upwardly compatible.

I asked a similar question here.

If it is of any conciliation I too have shot myself in the foot by trying to stay up to date with ESRI software when clients don't!

View solution in original post

Reply
0 Kudos
1 Reply
Highlighted
MVP Frequent Contributor

Short answer is no. You need a developer machine that has the same version if your client is using an older version of Arcmap. I have found addins are upwardly compatible.

I asked a similar question here.

If it is of any conciliation I too have shot myself in the foot by trying to stay up to date with ESRI software when clients don't!

View solution in original post

Reply
0 Kudos