ArcGis Engine

258
2
04-04-2013 07:13 AM
CollinsNdjawa
New Contributor II
Hi, I have ArcObjectsSDKNET (10sp3) and ArcGISEngine (10sp4). They can be install and work together or I need to have the same pack. Maybe ArcObjectsSDKNET (10sp3) and ArcGISEngine (10sp3)?

Thks
0 Kudos
2 Replies
oyleiste
Occasional Contributor
Why don't you just simply use last version you can?
If I were you, I would use sp4 on both.
0 Kudos
GhassanKarwchan
New Contributor III
Hi, I have ArcObjectsSDKNET (10sp3) and ArcGISEngine (10sp4). They can be install and work together or I need to have the same pack. Maybe ArcObjectsSDKNET (10sp3) and ArcGISEngine (10sp3)?

Thks


It is interesting question. I alaways installed the arcObjects with the same version as Engine, or Desktop.
I never tried otherwise.
But anyway, to think as a programmer.
The SDK .NET is just installing the wrapper or library interfaces to .NET on top of the already installed COM library.
So, the engine will install the real COM libraries, and SDK will install the wrapper to call them from .NET.

Now COM don't have versions (that I know of). so it might be that the .NET wrapper will be able to call the COM libraries of the engine.

So, logically as long as the wrapper are later than the engine (assuming it is backward compatible), then should not be a problem.

But you have the opposite. so it might work for most of the cases, but fail on some new features in Engine.

As I said, what I said, just "logical thinking", and practically I don't have any experience doing something like that.
0 Kudos