ArcGIS Engine Application Won't Run

3225
6
04-30-2014 01:42 AM
New Contributor III
i have created an ArcGIS Engine Application using 10.2.2 and VS 2010 .Net...

and installed the ArcGIS Runtime 10 in a separate computer...

the application was installed but when i try to run my application it just wont open...

can someone tell me what im missing...

the custom application have a license control added and ArcGIS Engine is checked...

i really need this done... im being rushed... hope someone can help me here...


thanks
Reply
0 Kudos
6 Replies
Occasional Contributor III
Do you have any error message to give us?  Without that it will be impossible to diagnose. 

One thing to check in the meantime.  Look in the ArcGIS administrator and see what licenses are available.  Make sure it is the correct license that you expected and that it is not expired. 

But even if you do not have a license, you should be getting an error message somewhere.  Check the event log.

Good Luck
Brent
Reply
0 Kudos
New Contributor III
thanks for responding Brent...

in ArcGIS Administrator the ArcGIS Engine Runtime is fine...
Have about a year before it expires...

and about the error... i can't catch it in code...

i got this after running the application installed...

Files that help describe the problem:
  C:\Users\GIS_2\AppData\Local\Temp\WER6AB2.tmp.WERInternalMetadata.xml
  C:\Users\GIS_2\AppData\Local\Temp\WER8A90.tmp.appcompat.txt
  C:\Users\GIS_2\AppData\Local\Temp\WER8B5C.tmp.mdmp

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
Reply
0 Kudos
New Contributor III
maybe what i really want to know is...

what is needed to be installed in a client pc for the custom application made from VS2010 and ArcGIS Engine Developers Kit to run.

i have added this in the MyApplication_Startup where the string is generated from License Viewer of Runtime SDK WPF using RUD license code in the same computer where i develop
ArcGISRuntime.SetLicense("")


and added this in LicenseInitializer
ESRI.ArcGIS.RuntimeManager.Bind(ESRI.ArcGIS.ProductCode.EngineOrDesktop)

        Dim supportedRuntimes() As ProductCode = New ProductCode() {ProductCode.Engine, ProductCode.Desktop}
        For Each c As ProductCode In supportedRuntimes
            If (RuntimeManager.Bind(c)) Then Return
        Next

        If (Not ESRI.ArcGIS.RuntimeManager.Bind(ESRI.ArcGIS.ProductCode.Engine)) Then
            If (Not ESRI.ArcGIS.RuntimeManager.Bind(ESRI.ArcGIS.ProductCode.Desktop)) Then
                MsgBox("ArcGIS runtime binding failed. Application will shut down.")
            End If

        End If


i am using 3 machines to test my application where i installed the following
pc 1 - ArcGIS Engine Runtime 10 using the EDN Dev. Kit License
pc 2 - ArcGIS Desktop
pc 3 - ArcGIS Engine Runtime SDK for Java

in PC 1 and PC 3 when i run the application i just get a error saying "The Application has stopped working."

and in PC 2 got the application running just until a message appear "This control requires an ArcGIS Engine Developer Kit License."
maybe its because only Desktop is installed in that machine...

and now im stuck...
Reply
0 Kudos
Occasional Contributor III
I almost looks like a Microsoft problem.   If you can't catch the error, you should be able to locate the offending line by peppering the code with message boxes.  It may not even make it to the ESRI code.

If you are not binding you should get a prettier error message:  "ArcGIS version not specified.  You must call RuntimeManager.Bind before creating any ArcGIS components."  or

"Failed to bind to an ArcGIS Engine runtime.  Ensure the specified runtime is installed before running this application".


The message on PC2 would tell me that you used to have a valid license for it, but the license has timed out.  PC1 and 3 almost sound like DotNet Framework errors.

Also there is an ESRI.ArcGIS.ProductCode.EngineOrDesktop option so you shouldn't have to individually check for both.

The following has always been sufficient for me:
           
ESRI.ArcGIS.RuntimeManager.Bind(ESRI.ArcGIS.ProductCode.EngineOrDesktop);
ESRI.ArcGIS.RuntimeManager.BindLicense(ESRI.ArcGIS.ProductCode.EngineOrDesktop);
Reply
0 Kudos
New Contributor III
Thanks again brent...

will try to install other frameworks to the pc to see if the problem will be resolved...

and will also try putting only

ESRI.ArcGIS.RuntimeManager.Bind(ESRI.ArcGIS.ProductCode.EngineOrDesktop)
ESRI.ArcGIS.RuntimeManager.BindLicense(ESRI.ArcGIS.ProductCode.EngineOrDesktop)


in the licenseinitializer and see what will happen...

but is it really possible to run a application built in ArcGIS Engine Development Kit to run in a Desktop License only?
Reply
0 Kudos
New Contributor III
Here's an update...

Don't know if this is a bug or what...

But I have made the Custom Application work on a Desktop License...

What i have found out is that there is nothing wrong in the codes but in the Ax Controls...

When i enable the Preview in Design Mode the applications in looking for the Developers Kit License...

But when it is disabled the application will run...

Hope this can help others with the same problem...

Thanks for answering Brent... how can i give you the point? 🙂
Reply
0 Kudos